Bug 1010776 - Sticky keys with tigervnc in F-19
Sticky keys with tigervnc in F-19
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 00:41 EDT by Bill McGonigle
Modified: 2015-11-04 14:31 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 607866
Environment:
Last Closed: 2015-02-17 12:18:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill McGonigle 2013-09-23 00:41:34 EDT
+++ This bug was initially created as a clone of Bug #607866 +++

I think I'm seeing some variant of the sticky keys bug in f19.  This has happened a few times now.   I'm using tigervnc server and tigervnc viewer, both running on the same machine.   I was 100% stable on f16 previously.

What I'm seeing is that all of the lower case keys stop working and my F keys won't work, as if SHIFT-F12 (e.g.) is being hit instead of F12.

If I get a text field to type in (mouse works) I can type all of the upper case characters but none of the lower case ones.  What's odd, is that if I type my lower case characters, I do *NOT* get upper case characters, as if an actual SHIFT were being held down, but rather when I type SHIFT A, I get a capital A, as expected.

I tried logging into a VT and running 'DISPLAY=:2 xev' and switching back to X and typing, and I'm not seeing anything come through for the lower case letters.

I tried restarting my window manager, clearing shift with xmodeset -e and didn't get anything to recover short of restarting the VNC Server.  Closing the client and re-connecting does not help.

$ rpm -q tigervnc-server tigervnc
tigervnc-server-1.3.0-3.fc19.x86_64
tigervnc-1.3.0-3.fc19.x86_64

$ grep -v '^#' /etc/systemd/system/vncserver@\:2.service


[Unit]
Description=Remote desktop service (VNC)
After=syslog.target network.target

[Service]
Type=simple
ExecStartPre=/bin/sh -c '/usr/bin/vncserver -kill %i > /dev/null 2>&1 || :'
ExecStart=/sbin/runuser -l bill -c "/usr/bin/vncserver -fg %i -geometry 1920x1200 -nolisten tcp -localhost"

[Install]
WantedBy=multi-user.target
Comment 1 Tim Waugh 2013-10-02 09:08:00 EDT
This update was pushed live recently:
https://admin.fedoraproject.org/updates/FEDORA-2013-17650

Do you still see the problem when using tigervnc-1.3.0-7.fc19? Just 'yum update "tigervnc*"' should bring in all the updated packages.
Comment 2 Bill McGonigle 2013-10-02 12:13:01 EDT
It sure looks like a dupe of bug 989502 as tapping the right shift key has unstuck it before (though I didn't figure out that it was left then right that made it work).   I'll leave NEEDINFO set until I restart the server and avoid the issue - it's usually just a few days between occurrences.
Comment 3 Fedora End Of Life 2015-01-09 14:57:02 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2015-02-17 12:18:59 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 5 Bill McGonigle 2015-11-04 14:31:27 EST
clearing needinfo from obsolete bug (sorry for the bugspam).

Note You need to log in before you can comment on or make changes to this bug.