Bug 1010805 - Temperature only shows in VNC session but not on local session
Temperature only shows in VNC session but not on local session
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mate-panel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 02:00 EDT by Aaron Lu
Modified: 2014-06-28 00:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 07:36:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot for local session and VNC session (209.60 KB, image/jpeg)
2013-09-23 02:00 EDT, Aaron Lu
no flags Details
Location and unit setting of weather (68.21 KB, image/jpeg)
2013-09-23 10:34 EDT, Aaron Lu
no flags Details
No weather displayed on home laptop (124.11 KB, image/jpeg)
2013-09-24 07:02 EDT, Aaron Lu
no flags Details

  None (edit)
Description Aaron Lu 2013-09-23 02:00:16 EDT
Created attachment 801493 [details]
Screenshot for local session and VNC session

Description of problem:
The temperature doesn't show up after I set up location. In VNC session of the same computer, however, it can correctly show up. See attached picture.

Not sure if I chose the correct component, please reassign if I made a mistake here, thanks.

Version-Release number of selected component (if applicable):
mate-panel-1.6.1-4.fc19.x86_64
libmateweather-data-1.6.2-3.fc19.noarch
libmateweather-1.6.2-3.fc19.x86_64

How reproducible:
Always for local session, for VNC session, it is always OK.

Steps to Reproduce:
1. Log in to mate.
2.
3.

Actual results:
Temperature doesn't show up

Expected results:
Temperature shows up

Additional info:
I don't think this has anything to do with network proxy, but just in case, I'll mention it that the computer is in a company network, proxy is used. The proxy setting is done in System->Preference->Network Proxy, so should be the same for local session and VNC session.
Comment 1 Wolfgang Ulbrich 2013-09-23 05:13:28 EDT
Did you set the temerature/Wind speed units in the weather tap of preferences of the clock applet?
Comment 2 Aaron Lu 2013-09-23 06:58:12 EDT
Yes I did, or the temperature wouldn't show up in VNC session I think. Thanks for the quick response!
Comment 3 Aaron Lu 2013-09-23 07:06:19 EDT
I just tested my home laptop, both local session and VNC session don't have temperature show up...no proxy used at home this time.
Comment 4 Wolfgang Ulbrich 2013-09-23 07:13:37 EDT
I did ask you about setting the units, because it isn't set after installation.
Can you connect to http://weather.noaa.gov/ in a browser?
Comment 5 Aaron Lu 2013-09-23 10:34:00 EDT
Created attachment 801681 [details]
Location and unit setting of weather

Yes, I can connect there and see weather of Shanghai-Hongqiao. Attached an image of my setting.
Comment 6 Wolfgang Ulbrich 2013-09-23 11:46:30 EDT
Ok, the settings are fine.
For getting a debug output,
1. can you remove the clock applet from the panel?
2. open a terminal and start the clock applet with '/usr/libexec/mate-panel/clock-applet --sync'
2. open a second terminal and start 'mate-panel-test-applets'
3. sart the applet from the popup window.
4. do your settings in preferences
Did you see any abnormal in the first terminal?

Anotherthing, does the the weather displayed with the weather applet?
Comment 7 Aaron Lu 2013-09-23 21:14:08 EDT
The first window has a warning:
[aaron@aaronlu ~]$ /usr/libexec/mate-panel/clock-applet --sync

(clock-applet:1470): MateWeather-WARNING **: Conversion to illegal temperature unit: 1

And the weather displayed correctly with the weather applet.
Comment 8 Aaron Lu 2013-09-23 21:14:50 EDT
(In reply to Aaron Lu from comment #7)
> The first window has a warning:

the first window -> the first terminal

> [aaron@aaronlu ~]$ /usr/libexec/mate-panel/clock-applet --sync
> 
> (clock-applet:1470): MateWeather-WARNING **: Conversion to illegal
> temperature unit: 1
> 
> And the weather displayed correctly with the weather applet.
Comment 9 Wolfgang Ulbrich 2013-09-24 05:53:20 EDT
(In reply to Aaron Lu from comment #7)
> The first window has a warning:
> [aaron@aaronlu ~]$ /usr/libexec/mate-panel/clock-applet --sync
> 
> (clock-applet:1470): MateWeather-WARNING **: Conversion to illegal
> temperature unit: 1
> 
> And the weather displayed correctly with the weather applet.

This is weird, because clock-applet and weather-appplet use both libmateweather and same weather server for displaying the weather.
But clock-applet says using the 'metric' system is wrong.
Can you do the same test with using other units, fahrenheit or kalvin?
Here in Europe/Berlin i have no probs too use weather data with celsius unit.

And at your home with your laptop you have same results?
Comment 10 Aaron Lu 2013-09-24 05:55:32 EDT
I'm now heading for home and will test later, thanks.
Comment 11 Aaron Lu 2013-09-24 07:02:49 EDT
Created attachment 802179 [details]
No weather displayed on home laptop

This time, on my home laptop, there is no weather displayed after I did the settings of the test clock applet and thus no warning message emitted on the first terminal...
Comment 12 Aaron Lu 2013-09-24 07:05:35 EDT
(In reply to Aaron Lu from comment #11)
> Created attachment 802179 [details]
> No weather displayed on home laptop
> 
> This time, on my home laptop, there is no weather displayed after I did the
> settings of the test clock applet and thus no warning message emitted on the
> first terminal...

ANd it doesn't matter which unit I chose on my home laptop, either with test clock applet or with the clock applet on panel, no weather displayed.
Comment 13 Aaron Lu 2013-09-24 07:14:42 EDT
I just vpn-ed to my office desktop, it turned out the warning message is dumped right after I added the location, but before set the temperature unit. So it seems that warning makes sense? After I chose a unit, the weather can correctly display(before that it would display Unknown, which is also different than the symptom on my home laptop, where it simply displayed nothing except the digital clock).
Comment 14 Wolfgang Ulbrich 2013-09-25 04:21:25 EDT
(In reply to Aaron Lu from comment #13)
> I just vpn-ed to my office desktop, it turned out the warning message is
> dumped right after I added the location, but before set the temperature
> unit. So it seems that warning makes sense?
yes, that makes sense.
Can you give me the output of
grep -i "libmateweather" /var/log/yum.log
And if you find an older version than the installed version, can you remember if it was working correct with the older version?
I did disable python support in latest build because of an obsolete dependency for rawhide, maybe this cause the issue.
Also there is a change for finding weather location in upstream which comes with the 1.6.2 release.
Comment 15 Aaron Lu 2013-09-25 04:51:18 EDT
[root@aaronlu proc]# grep -i "libmateweather" /var/log/yum.log
Jul 31 13:00:06 Installed: libmateweather-1.6.1-1.fc19.x86_64
Aug 19 13:08:08 Erased: libmateweather-1.6.1-1.fc19.x86_64
Aug 22 10:52:33 Installed: libmateweather-1.6.2-1.fc19.x86_64
Sep 13 10:45:53 Erased: libmateweather-1.6.2-1.fc19.x86_64
Sep 13 11:01:59 Installed: libmateweather-1.6.2-2.fc19.x86_64
Sep 16 08:51:51 Updated: libmateweather-1.6.2-3.fc19.x86_64
Sep 16 08:51:53 Installed: libmateweather-data-1.6.2-3.fc19.noarch
Sep 25 08:55:37 Installed: libmateweather-devel-1.6.2-3.fc19.x86_64

I vaguely remembered the old version doesn't work either, I can downgrade to test later.
Comment 16 Aaron Lu 2013-09-25 05:04:43 EDT
I've downgraded libmateweather to 1.6.1-1, but there doesn't seem to be the corresponding libmateweather-data-1.6.1-1 package, so I end up with only the libmateweather-1.6.1-1 package and it doesn't work.
Comment 17 Wolfgang Ulbrich 2013-09-25 05:18:51 EDT
Thank you,
yeah, with 1.6.2.2 libmateweather is splited for packaging reasons (fedora guide lines).
But don't use 1.6.2-2 which is worse.
That it don't work  with 1.6.1 too, shows me that the changes aren't the reason for the issue.
Comment 18 Wolfgang Ulbrich 2013-09-25 05:28:46 EDT
I did informed upstream about the issue.
https://github.com/mate-desktop/libmateweather/issues/13
Comment 19 Wolfgang Ulbrich 2013-09-25 06:22:42 EDT
upstream asked for
dconf read /org/mate/panel/objects/clock/prefs/cities

This won't be work in our case because of the remove of the clock-applet for testing.
Use
dconf read /org/mate/panel/objects/object_22/prefs/cities
Replace '22' with your current number for the applet, see in dconf-editor.

Can you post the resulting output direct to upstream?
https://github.com/mate-desktop/libmateweather/issues/13
Comment 20 Aaron Lu 2013-09-25 06:52:03 EDT
Done.

[aaron@aaronlu ~]$ dconf read /org/mate/panel/objects/object_2/prefs/cities
['<location name="" city="Shanghai" timezone="Asia/Shanghai" latitude="31.166668" longitude="121.433334" code="ZSSS" current="true"/>']

I omitted the ['< and >'] because it makes the whole line empty on github issue, dunno why...
Comment 21 Wolfgang Ulbrich 2013-09-25 07:05:11 EDT
Let us work further at github for the issue, because there are more people involved.
Comment 22 Aaron Lu 2013-09-25 07:05:55 EDT
Something interesting happened, I just made the weather show up on my home laptop. I did:
1 Set preference of the clock applet
2 left click the clock appet, the calendar show up, then press Locations, and Shanghai(which is I chose) showed on the left bottom, and to the right side, there is a word 'Set', I pressed 'Set', it asked me password, then I entered password and it said something like set timezone, and the weather showed up now. Also, the place for the word 'Set' changed to an icon of home.

After this setting, there is one change regarding the dconf reading of cities.
Previously, the current="false" on my home laptop(not the same case of my office desktop), after I set the timezone, it became current=true(the same as my office desktop).

I was inspired by timcowchip's comment here:
https://github.com/mate-desktop/mate-panel/issues/25
Though I do not need to re-set the timezone agin after reboot.
Comment 23 Aaron Lu 2013-09-25 07:06:18 EDT
(In reply to Wolfgang Ulbrich from comment #21)
> Let us work further at github for the issue, because there are more people
> involved.

OK, thanks for taking care of this.
Comment 24 Wolfgang Ulbrich 2013-09-25 09:45:50 EDT
Ok, we have track down the issue more. Changing the weather location could be be also change the system time, which isn't allowed for a normal user account by this policy.
org.mate.settingsdaemon.datetimemechanism.settime
We was forced to change the policy from
auth_self_keep
to
auth_admin_keep
by this rhbz report.
https://bugzilla.redhat.com/show_bug.cgi?id=878102

I think your office system was installed with another timezone location than Shanghai.
In you screenshots i saw you're working for intel, right?
So i think the system was installed with 'Us' location first.
It seems that if you use vnc-session you've admin rights and won't be bother by this policy.
Comment 25 Sergei S. Rublev 2014-06-28 00:55:05 EDT
Got the alike issue on Fedora RFremix 20 — no weather in clock panel of MATE despite "Show weather" option enabled and temperature/wind units set. After reading thread, I found out that I have to CLICK ON MY LOCATION in pull-down menu (even if it's single) to SET LOCATION AS CURRENT AND USE THIS TIMEZONE ("Сделать местность текущей и использовать этот часовой пояс"). The problem occurs where THERE IS NO ICON OF HOUSE _next to location to the left_. Pointing at this _empty space_ shows up description plaque and clicking it makes icon of house appear and the weather is visible now.

Note You need to log in before you can comment on or make changes to this bug.