Bug 1010816 - beaker-repo-update only updates harness repo for one family
beaker-repo-update only updates harness repo for one family
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.15
: ---
Assigned To: Raymond Mancy
tools-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 02:29 EDT by Dan Callaghan
Modified: 2014-12-07 20:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 22:27:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2013-09-23 02:29:13 EDT
Description of problem:
beaker-repo-update only updates harness repo for one family.

Version-Release number of selected component (if applicable):
unreleased 0.14.1-1.git.205.7c96e3a

How reproducible:
always

Steps to Reproduce:
1. Run beaker-repo-update

Actual results:
Fetches (or skips) RPMs for one distro family (on beaker-devel, it's RHEL5 Server) and then exits.

Expected results:
Should fetch harness RPMs for all distro families.

Additional info:
Regression on develop due to: http://git.beaker-project.org/cgit/beaker/commit/?id=08baba18dc6abb92b43c86241777c25ca1500625
This got it working on beaker-devel: http://paste.fedoraproject.org/41446/17517137
Comment 1 Raymond Mancy 2013-09-24 00:10:47 EDT
http://gerrit.beaker-project.org/#/c/2286/
Comment 2 Raymond Mancy 2013-09-24 02:23:21 EDT
Steps to verify:-

1) Add two or more new distros to harness repos, or add new packages
2) Run beaker-repo-update against that particular harness repo
3) It should import packages for more than one distro
Comment 4 Nick Coghlan 2013-10-02 22:27:06 EDT
Beaker 0.15 has been released.

Note You need to log in before you can comment on or make changes to this bug.