Bug 101083 - snmpd stops working
snmpd stops working
Status: CLOSED DUPLICATE of bug 82146
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-snmp (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Depends On:
Blocks: 101028
  Show dependency treegraph
Reported: 2003-07-28 19:23 EDT by Christopher McCrory
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:57:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christopher McCrory 2003-07-28 19:23:22 EDT
Description of problem:

snmpd starts up , then soon fails

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. startup snmpd
2. snmpwalk localhost
Actual results:

[chrismcc@abu tmp]$ !snmpwalk
snmpwalk -v1  localhost -c public
SNMPv2-MIB::sysDescr.0 = STRING: Linux abu 2.4.21-1.1931.2.349.2.2.entsmp #1 SMP
Fri Jul 18 00:22:59 EDT 2003 i686
SNMPv2-MIB::sysObjectID.0 = OID: NET-SNMP-MIB::netSnmpAgentOIDs.10
SNMPv2-MIB::sysUpTime.0 = Timeticks: (1298) 0:00:12.98
SNMPv2-MIB::sysContact.0 = STRING: Root <root@localhost> (configure
SNMPv2-MIB::sysName.0 = STRING: abu
SNMPv2-MIB::sysLocation.0 = STRING: Unknown (edit /etc/snmp/snmpd.conf)
SNMPv2-MIB::sysORLastChange.0 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORID.2 = OID: SNMPv2-MIB::snmpMIB
SNMPv2-MIB::sysORID.4 = OID: IP-MIB::ip
SNMPv2-MIB::sysORID.7 = OID: SNMP-FRAMEWORK-MIB::snmpFrameworkMIBCompliance
SNMPv2-MIB::sysORID.8 = OID: SNMP-MPD-MIB::snmpMPDCompliance
SNMPv2-MIB::sysORDescr.1 = STRING: The MIB module to describe generic objects
for network interface sub-layers
SNMPv2-MIB::sysORDescr.2 = STRING: The MIB module for SNMPv2 entities
SNMPv2-MIB::sysORDescr.3 = STRING: The MIB module for managing TCP implementations
SNMPv2-MIB::sysORDescr.4 = STRING: The MIB module for managing IP and ICMP
SNMPv2-MIB::sysORDescr.5 = STRING: The MIB module for managing UDP implementations
SNMPv2-MIB::sysORDescr.6 = STRING: View-based Access Control Model for SNMP.
SNMPv2-MIB::sysORDescr.7 = STRING: The SNMP Management Architecture MIB.
SNMPv2-MIB::sysORDescr.8 = STRING: The MIB for Message Processing and Dispatching.
SNMPv2-MIB::sysORDescr.9 = STRING: The management information definitions for
the SNMP User-based Security Model.
SNMPv2-MIB::sysORUpTime.1 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.2 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.3 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.4 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.5 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.6 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.7 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.8 = Timeticks: (0) 0:00:00.00
SNMPv2-MIB::sysORUpTime.9 = Timeticks: (0) 0:00:00.00
HOST-RESOURCES-MIB::hrSystemUptime.0 = Timeticks: (7350388) 20:25:03.88
Timeout: No Response from localhost

[chrismcc@abu tmp]$ snmpwalk -v1  localhost -c public
Timeout: No Response from localhost

Expected results:

lots more info :)

Additional info:

also tried net-snmp rpms from RH9 , same result ( same rpms work on my RH9 system)

[chrismcc@abu SRPMS]$ rpmbuild --rebuild net-snmp-5.0.6-17.src.rpm
/bin/sh ../libtool  --mode=link gcc -I/usr/include/rpm -DINET6 -O2 -g -pipe -mar
ch=i386 -mcpu=i686 -Dlinux -I/usr/include/rpm -o snmpd snmpd.lo   libnetsnmpagen
t.la libnetsnmpmibs.la helpers/libnetsnmphelpers.la -L/usr/lib/lib -lwrap ../snm
plib/libnetsnmp.la -ldl -lrpm -lrpmio -lpopt  -lbz2 -lz -lcrypto -lm
libtool: link: cannot find the library `/usr/lib/libbeecrypt.la'
make[1]: *** [snmpd] Error 1
make[1]: Leaving directory `/home/chrismcc/redhat/BUILD/net-snmp-5.0.6/agent'
make: *** [subdirs] Error 1
error: Bad exit status from /home/chrismcc/redhat/tmp/rpm-tmp.15446 (%build)

beecrypt problem ? ? ?
Comment 1 Phil Knirsch 2003-07-31 08:07:19 EDT
Know problem (see duplicate).

And the rebuild fails because of the missing beecrypt-devel package (fixed in
latest CVS version, should hit rawhide sometime soon).

Read ya, Phil

*** This bug has been marked as a duplicate of 82146 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.