This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1010834 - No error is reported when files are in extended-attribute split-brain state.
No error is reported when files are in extended-attribute split-brain state.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ravishankar N
:
Depends On: 1006354
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 03:06 EDT by Ravishankar N
Modified: 2014-04-17 07:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1006354
Environment:
Last Closed: 2014-04-17 07:48:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-23 03:08:56 EDT
REVIEW: http://review.gluster.org/5988 (afr: check for split-brain before proceeding with fops) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Anand Avati 2013-09-23 07:26:29 EDT
REVIEW: http://review.gluster.org/5988 (afr: check for split-brain before proceeding with fops) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Anand Avati 2013-09-24 23:57:07 EDT
REVIEW: http://review.gluster.org/5988 (afr: check for split-brain before proceeding with fops) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 4 Anand Avati 2013-09-26 08:41:12 EDT
REVIEW: http://review.gluster.org/5988 (afr: check for split-brain before proceeding with fops) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 5 Anand Avati 2013-10-03 04:47:53 EDT
REVIEW: http://review.gluster.org/5988 (afr: check for split-brain before proceeding with fops) posted (#5) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 6 Anand Avati 2013-10-03 07:38:44 EDT
REVIEW: http://review.gluster.org/5988 (afr: check for split-brain before proceeding with fops) posted (#6) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 7 Anand Avati 2013-10-03 08:36:56 EDT
REVIEW: http://review.gluster.org/5988 (afr: check for split-brain before proceeding with fops) posted (#7) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 8 Anand Avati 2013-10-15 13:21:24 EDT
REVIEW: http://review.gluster.org/5988 (afr: check for split-brain before proceeding with fops) posted (#8) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 9 Anand Avati 2013-10-16 22:30:25 EDT
COMMIT: http://review.gluster.org/5988 committed in master by Anand Avati (avati@redhat.com) 
------
commit dfe698bae7f4bbc5f506d29473888239a82156fc
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Tue Oct 15 22:37:44 2013 +0530

    afr: check for split-brain before proceeding with fops
    
    Bail out of fops if split brain has been detected during lookup
    
    Change-Id: Id387dbb1a25eec4a121dedceadc6069bdea24b5d
    BUG: 1010834
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5988
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 10 Anand Avati 2013-12-01 12:43:19 EST
REVIEW: http://review.gluster.org/6385 (cluster/afr: Fix description string for option 'self-heal-daemon') posted (#1) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 11 Anand Avati 2013-12-03 00:48:22 EST
COMMIT: http://review.gluster.org/6385 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit cb7832895257dd22258e360f6a596b09ba7c20ac
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Sun Dec 1 20:11:24 2013 +0530

    cluster/afr: Fix description string for option 'self-heal-daemon'
    
    Change-Id: I267b935a16a6fdc72a4e791f681289e6868baee6
    BUG: 1010834
    Reviewed-on: http://review.gluster.org/6385
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 12 Niels de Vos 2014-04-17 07:48:26 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.