Bug 1010841 - Installation of RHQ server fails - de-obfuscating db password failed
Installation of RHQ server fails - de-obfuscating db password failed
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
Unspecified Unspecified
urgent Severity urgent
: ER02
: JON 3.2.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: jon32-Beta-Blockers-1006862
  Show dependency treegraph
 
Reported: 2013-09-23 03:42 EDT by Filip Brychta
Modified: 2014-01-02 15:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:37:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
complete rhq server log (421.21 KB, text/x-log)
2013-09-23 03:42 EDT, Filip Brychta
no flags Details

  None (edit)
Description Filip Brychta 2013-09-23 03:42:50 EDT
Created attachment 801530 [details]
complete rhq server log

Description of problem:
Rhq server is started but not accessible via browser after installation throwing following exception to the rhq server log:
erverInvokerServlet: invokerObjectNameQuery=jboss.remoting:service=invoker,rhq.communications.connector.rhqtype=server,*
03:25:26,245 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/jboss-remoting-servlet-invoker].[ServerInvokerServlet]] (http-/0.0.0.0:7080-1) JBWEB000235: Allocate exception for servlet ServerInvokerServlet: javax.servlet.ServletException: Could not find the remoting servlet invoker: jboss.remoting:service=invoker,rhq.communications.connector.rhqtype=server,* - need to wait for remoting to be initialized later



Version-Release number of selected component (if applicable):
rhq-server-4.10.0-SNAPSHOT
1ba590c19821808a42c6b59e4cdea319686b7b96

How reproducible:
Always

Steps to Reproduce:
1. have a clean environment (without any files left from previous installations)
2. unzip rhq-server-4.10.0-SNAPSHOT.zip
3. set 'jboss.bind.address' property in bin/rhq-server.properties
4. ./rhqctl install

Actual results:
Installer finishes without any error. Rhq storage, server and agent are started but rhq server is not accessible via browser.

Expected results:
installation works

Additional info:
Suspicious exceptions from rhq serve log:
03:17:32,033 ERROR [org.jboss.as.ejb3.invocation] (pool-9-thread-1) JBAS014134: EJB Invocation failed on component StorageClientManagerBean for method public synchronized void org.rhq.enterprise.server.storage.StorageClientManagerBean.init(): javax.ejb.EJBException: java.lang.RuntimeException: java.lang.RuntimeException: de-obfuscating db password failed:
.
.
Caused by: java.lang.NumberFormatException: Zero length BigInteger



NPE exception:
03:17:32,098 ERROR [org.jboss.as.ejb3.invocation] (pool-9-thread-1) JBAS014134: EJB Invocation failed on component SchedulerBean for method public abstract void org.rhq.enterprise.server.scheduler.SchedulerServiceMBean.shutdown(boolean) throws org.quartz.SchedulerException: javax.ejb.EJBException: java.lang.NullPointerException
.
.
Caused by: java.lang.NullPointerException
        at org.rhq.enterprise.server.scheduler.SchedulerService.shutdown(SchedulerService.java:204



See complete attached rhq server log.
Comment 1 Jay Shaughnessy 2013-09-26 12:37:24 EDT
commit 09c7e488dcc099d890482de94e6a6098018a7e4b
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Thu Sep 26 12:35:08 2013 -0400

Fix in a way that won't suffer from ambiguity or db vendor incompatibilities.
Comment 3 Simeon Pinder 2013-09-28 14:44:53 EDT
With the additional two commits(in order) this is fixed in ER2 build(https://brewweb.devel.redhat.com//buildinfo?buildID=297200):
14b71da818992a
371eac0020bc69

Moving this to ON_QA.
Comment 4 Filip Brychta 2013-09-30 05:14:56 EDT
Verified on 
Version: 3.2.0.ER2
Build Number: 9bf6f76:371eac0

Note You need to log in before you can comment on or make changes to this bug.