Bug 1010847 - Strange behaviour of setting transaction log-store via jboss-cli
Strange behaviour of setting transaction log-store via jboss-cli
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER8
: EAP 6.3.0
Assigned To: Stefano Maestri
Ondrej Chaloupka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 03:54 EDT by Ondrej Chaloupka
Modified: 2017-10-09 20:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 10:40:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-3495 Major Resolved /subsystem=transactions/log-store=log-store type attribute should be read-only 2014-07-31 08:39:57 EDT

  None (edit)
Description Ondrej Chaloupka 2013-09-23 03:54:12 EDT
There is non-standard behavior of log-store "address" in jboss-cli.

If you want to change log store type via jboss-cli I suppose that supposed way is via command like:
 /subsystem=transactions:write-attribute(name=use-hornetq-store, value=true)
similarly with jdbc store.

But there is a second way how to get name the transaction object store in use:
/subsystem=transactions/log-store=log-store:read-attribute(name=type)

But when you try to set the type via this way:
/subsystem=transactions/log-store=log-store:write-attribute(name=type, value=hornetq)

you'll get operation success
{
    "outcome" => "success",
    "response-headers" => {
        "operation-requires-reload" => true,
        "process-state" => "reload-required"
    }
}
but no change in the model is realized.

There should be some info to user that this way is not supported or this way should correctly work.
Comment 1 Brian Stansberry 2013-09-23 04:39:49 EDT
The CLI component is for the client side tool. Please do not use it for issues related to server side behavior. In cases like this where the issue relates to low level operations, you're describing server side issues.
Comment 2 Ivo Studensky 2013-09-25 05:05:53 EDT
This issue seems to be related to the Narayana integration part, thus I am re-assigning it to Stefano. 

From my PoV the log-store attribute should be read-only and documentation fixed.
Comment 3 Chao Wang 2013-09-25 06:52:21 EDT
For EAP 6, according to attributes description of use-hornetq-store and log-store under Table 15.2 https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6/html/Administration_and_Configuration_Guide/chap-Transaction_Subsystem.html

Both attributes should be set if write one of them. 
However, for EAP 6.1 Table 18.2 https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Administration_and_Configuration_Guide/chap-Transaction_Subsystem.html it does not mention this part.

Agreed with Ivo to set to read-only attribute, if we keep that two attributes synchronization for further release then maybe we could use a new handler extends AbstractWriteAttributeHandler to achieve that.
Comment 4 Ondrej Chaloupka 2013-09-25 07:13:24 EDT
I Agree. The read-only property for the attribute would solve this problem.
Thank you
Ondra
Comment 5 Stefano Maestri 2014-06-13 11:26:02 EDT
PR sent

https://github.com/jbossas/jboss-eap/pull/1456
Comment 6 Ondrej Chaloupka 2014-07-02 04:06:44 EDT
Command
/subsystem=transactions/log-store=log-store:write-attribute(name=type, value=hornetq)
is set as read only and it can't be modified that way.

Verified for EAP 6.3.0.ER8

Note You need to log in before you can comment on or make changes to this bug.