Bug 1010880 - Gui spinner quantity is displaying wrong quantity for Awesome OS x86_64(100000000000002.pem) with fully compliant instance based subscription.
Gui spinner quantity is displaying wrong quantity for Awesome OS x86_64(1000...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
John Sefler
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-09-23 05:00 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:29:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot after subscribe instance based subscription (27.92 KB, image/png)
2013-09-23 05:01 EDT, spandey
no flags Details
Change in quantity before and after subscription (621.53 KB, image/png)
2013-10-07 20:47 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description spandey 2013-09-23 05:00:29 EDT
Prerequisites:
Rhel6.5 physical machine with following subscription manager rpm.
subscription-manager-firstboot-1.9.6-1.git.3.5220cd8.el6.x86_64 
subscription-manager-1.9.6-1.git.3.5220cd8.el6.x86_64 
subscription-manager-migration-data-1.12.3.2-1.git.0.fe2ef86.el6.noarch 
subscription-manager-migration-1.9.6-1.git.3.5220cd8.el6.x86_64 
subscription-manager-gui-1.9.6-1.git.3.5220cd8.el6.x86_64 



Steps to Repro : 
Register physical rhel6.5 client to candlepin with following product cert  
 [root@dhcp201-196 facts]# ls /etc/pki/product/ 
100000000000002.pem  32060.pem (stacking and instance based product cert)
List available subscription for installed product . 
Subscribe Fully compliant instance based subscription.
Now check suggested quantity for  Awesome OS x86_64.

Expected Result : 
proper quantity should display .

Actual Result : 
Gui now displaying suggested  “0” quantity for  Awesome OS x86_64.

Note : value turned to “0 “ as soon as we fully subscribed to instance based subscription. 

If we subscribe  “Awesome OS x86_64” to compliant it changes suggested quantity for instance based subscription . 

Attached screen shot after subscribe value turned to “0” with instance based subscribe.
Comment 1 spandey 2013-09-23 05:01:44 EDT
Created attachment 801550 [details]
screenshot after subscribe instance based subscription
Comment 3 Carter Kozak 2013-09-23 09:33:13 EDT
I'm not sure I would call this a bug, however this behavior is changed in master.  0 more subscriptions are required to make that product valid, but I agree that it's weird because that entitlement could provide different content.

commit c67def26a24c2a43c1133995ad08ed27d18bb86d
Author: ckozak <ckozak@redhat.com>
Date:   Tue Sep 17 11:57:02 2013 -0400

    1007836: calculate suggested quantity with only matching stacking_ids
Comment 6 Sharath Dwaral 2013-10-07 20:47:07 EDT
Created attachment 809029 [details]
Change in quantity before and after subscription

Version:

subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.9.9-1.el6
python-rhsm: 1.9.6-1.el6

# ls /etc/pki/product/
100000000000002_.pem  32060_.pem

=== Before Subscribing ===

# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Awesome OS Instance Server Bits
Product ID:     32060
Version:        6.1
Arch:           ALL
Status:         Not Subscribed
Status Details: 
Starts:         10/02/2013
Ends:           10/02/2014

Product Name:   Awesome OS for x86_64 Bits
Product ID:     100000000000002
Version:        3.11
Arch:           x86_64
Status:         Not Subscribed
Status Details: Not covered by a valid subscription.
Starts:         
Ends:


=== After Subscribing ===

# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Awesome OS Instance Server Bits
Product ID:     32060
Version:        6.1
Arch:           ALL
Status:         Subscribed
Status Details: 
Starts:         10/02/2013
Ends:           10/02/2014

Product Name:   Awesome OS for x86_64 Bits
Product ID:     100000000000002
Version:        3.11
Arch:           x86_64
Status:         Not Subscribed
Status Details: Not covered by a valid subscription.
Starts:         
Ends


It can be seen from the attachment that the quantity of Awesome OS for x86_64 does not change to '0'


VERIFIED
Comment 8 errata-xmlrpc 2013-11-21 16:29:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.