Bug 1010887 - [virtio-win][balloon] Guest display did not show properly after hibernate guest(s4)& resume after enlarging memory during runtime
Summary: [virtio-win][balloon] Guest display did not show properly after hibernate gue...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: 7.0
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-23 09:07 UTC by Mike Cao
Modified: 2015-11-24 08:39 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:39:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (19.77 KB, image/png)
2013-09-23 09:09 UTC, Mike Cao
no flags Details
dump file when do s4 without balloon device (79.50 KB, application/octet-stream)
2013-09-23 09:41 UTC, Mike Cao
no flags Details
screenshot when guest hang (3.26 KB, image/png)
2013-09-23 11:24 UTC, Mike Cao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Mike Cao 2013-09-23 09:07:06 UTC
Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
2.6.32-419.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.404.el6.x86_64
spice-server-0.12.4-3.el6.x86_64
seabios-0.6.1.2-28.el6.x86_64

Guest : win2012
Steps to Reproduce: 
2/2 

Steps:

1. Start guest with virtio-balloon-pci,

CLI:/usr/libexec/qemu-kvm -name win2012  -M rhel6.5.0 -enable-kvm -m 3G -smp 2,sockets=2,cores=1,threads=1 -uuid 6ad42fad-761f-e082-aadc-c4096097c030 -nodefconfig -nodefaults -monitor unix:/tmp/tt,server,nowait -rtc base=localtime,driftfix=slew -boot order=dc,menu=on,once=c -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=win2012.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=mike_cao,cache=none -device ide-drive,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=en_windows_server_2012_x64_dvd_915478.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-0,id=ide0-1-0 -drive if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=52:54:00:b6:ff:a6,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga std -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0  -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 -global PIIX4_PM.disable_s4=0

2. balloon guest memory to 400MB

eg:(qemu)balloon 400

3. After step2 ,balloon guest memory to max

eg:(qemu)balloon 3072

4. #shutdown /h

eg: 

5. After 5mins ,resume guest w/ the same cli as step1

eg: CLI:/usr/libexec/qemu-kvm -name win2012 -M rhel6.5.0 -enable-kvm -m 3G -smp 2,sockets=2,cores=1,threads=1 -uuid 6ad42fad-761f-e082-aadc-c4096097c030 -nodefconfig -nodefaults -monitor unix:/tmp/tt,server,nowait -rtc base=localtime,driftfix=slew -boot order=dc,menu=on,once=c -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=win2012.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=mike_cao,cache=none -device ide-drive,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=en_windows_server_2012_x64_dvd_915478.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-0,id=ide0-1-0 -drive if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=52:54:00:b6:ff:a6,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga std -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0  -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 -global PIIX4_PM.disable_s4=0



Actual results: 
Guest did not show proerply ,it change into blank-and-write screen and the resolution change to 640*480 and change not change

Expected results:
Guest could change back to normal successfully


Additional info ,Did not reproduce this issue when doing hibernate w/o guest ballooning

Comment 1 Mike Cao 2013-09-23 09:09:11 UTC
Created attachment 801552 [details]
screenshot

Comment 2 Mike Cao 2013-09-23 09:41:19 UTC
Created attachment 801557 [details]
dump file when do s4 without balloon device

This may not related to virtio-win 

I retest s4 w/o -device virtio-balloon-pci , Guest shows "guest has been shutdown unexpectedly"

Comment 8 Mike Cao 2013-09-23 11:23:37 UTC
Doing the exact same steps 

Some times guest hang during resume .referring to screen dump

Comment 9 Mike Cao 2013-09-23 11:24:41 UTC
Created attachment 801580 [details]
screenshot when guest hang

Comment 12 Ronen Hod 2014-03-25 10:48:53 UTC
Since S4 is not supported, deferring to 7.1

Comment 14 Gal Hammer 2014-08-10 13:05:40 UTC
What is the balloon's driver version? Is it still reproducible?

Comment 15 Mike Cao 2014-08-12 10:16:36 UTC
(In reply to Gal Hammer from comment #14)
> What is the balloon's driver version? Is it still reproducible?

I can not reproduce it on RHEL7 host ,I will retest it on RHEL6 host tmr

3.10.0-121.el7.x86_64
qemu-kvm-1.5.3-62.el7.x86_64
virtio-win-prewhql-89

Comment 16 Mike Cao 2014-08-13 03:11:55 UTC
(In reply to Mike Cao from comment #15)
> (In reply to Gal Hammer from comment #14)
> > What is the balloon's driver version? Is it still reproducible?
> 
> I can not reproduce it on RHEL7 host ,I will retest it on RHEL6 host tmr
> 
> 3.10.0-121.el7.x86_64
> qemu-kvm-1.5.3-62.el7.x86_64
> virtio-win-prewhql-89

CLI:
/usr/libexec/qemu-kvm -name 089BLN201264RCR -enable-kvm -m 6G -smp 8 -uuid 22b6ef35-3d5f-4095-8686-44e4beba0242 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/089BLN201264RCR,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=089BLN201264RCR,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_x64_dvd_915478.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=089BLN201264RCR.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:68:0a:c0:33,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7

Comment 17 Gal Hammer 2014-08-21 11:10:34 UTC
Moving to ON_QA based on comment #15.

Comment 18 Yu Wang 2015-07-07 02:16:05 UTC
Verified this issue on virtio-win-prewhql-105 verion

Steps:
1./usr/libexec/qemu-kvm -name win2012 -enable-kvm -m 3G -smp 2 -uuid ae361e8d-28a4-4e70-8783-bda0d450ce35 -nodefconfig --nodefaults -chardev socket,id=charmonitor,path=/tmp/win2012,server,nowait -mon chardev=charmonitor,id=monitor1,mode=control -rtc base=localtime,driftfix=slew -boot order=dc,menu=on -drive file=win2012.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_x64_dvd_915478.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -vnc 0.0.0.0:0 -vga cirrus -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:5a:30:2e:60,bus=pci.0,addr=0x3 -device virtio-balloon-pci,id=balloon1,addr=0x9 -global PIIX4_PM.disable_s4=0 -monitor stdio

2.balloon guest memory to 400MB
  (qemu)balloon 400
3.After step2 ,balloon guest memory to max
  (qemu)balloon 3072
(steps same as comment #0)

Actual Results: 

on RHEL6 fix version:
virtio-win-prewhql-105
kernel-2.6.32-419.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.402.el6.x86_64

on RHEL7 fix version
virtio-win-prewhql-105
kernel-3.10.0-229.el7.x86_64
qemu-kvm-rhev-2.1.2-23.el7.x86_64

Comment 19 Yu Wang 2015-07-07 02:31:48 UTC
Try to reproduce this issue on virtio-win-prewhql-105 verion

Steps:
same as comment #0

Actual Results: 
Guest could change back to normal successfully.

Based on above ,this issue cannot be reproduced on virtio-win-prewhql-105 verion.

on RHEL6 fix version:
virtio-win-prewhql-105
kernel-2.6.32-419.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.402.el6.x86_64

on RHEL7 fix version
virtio-win-prewhql-105
kernel-3.10.0-229.el7.x86_64
qemu-kvm-rhev-2.1.2-23.el7.x86_64

Comment 20 lijin 2015-07-17 06:57:07 UTC
change status to verified according to comment#19

Comment 23 errata-xmlrpc 2015-11-24 08:39:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.