Bug 1010905 - Ensure consistency of field properties for all types
Ensure consistency of field properties for all types
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER2
: 6.0.1
Assigned To: Neus Miras
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 05:36 EDT by Pedro Zapata
Modified: 2014-08-06 16:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:03:55 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Zapata 2013-09-23 05:36:30 EDT
The consistency of availability, syntax and working mode of the following properties needs to be verified for all field types.
- Formula	
- Range Value	
- Pattern	
- Default value formula		

Also all the visualization options need verification to ensure consistency across fields, since there are some gaps in the support matrix.
Comment 2 Neus Miras 2013-10-01 05:49:31 EDT
The field properties has been reviewed

DefaultValueFormula size=55
Review of form identifiers
Added maxlength to inputTextEmail
Removed disabled property from systemForms
Removed maxlenght from date 
Removed groupWhithPreviuos
Removed required property form subform and Multiplesubform 


Commits:

Master
https://github.com/droolsjbpm/jbpm-form-modeler/commit/2410bd4a8d2174df6281f496a37341f9b59dceb6

6.0.x 
https://github.com/droolsjbpm/jbpm-form-modeler/commit/54deef55d5732c22a33cab330cfa45d0f5fac09c
Comment 3 Jan Hrcek 2013-10-21 02:12:22 EDT
The commit to fix this issue is not included in BPMS 6.0.0 ER4. Changing status to modified - will verify with the next release.
Comment 4 Jan Hrcek 2014-02-06 01:20:12 EST
Hello Pedro,
I have some doubts about this bugzilla which I'm supposed to verify now.
I can confirm, that the commit mentioned in comment 2 is present in BPMS 6.0.0 CR2. But I feel, that there are still some inconsistencies in the properties available for some field types.
-----------------------------------
Here are the discrepancies I found:

Field type: CheckBox:
Missing property: FORMULA - it makes sense to calculate the boolean value (checked/unchecked) based on values of some other fields.

Field types: Long integer, Integer, Short, Big Integer, Big Decimal:
Missing property: PATTERN - I don't get it why we should be unable to specify pattern for these field types, if for example Fload and Double (decimal types) specify it. At minimum: Big Decimal is also decimal type (as Fload & Double), so why not enable specifying pattern for it as well?

Field type: Long Text
Missing property: Show HTML - because field type Short Text HAS property Show HTML, why should Long Text not have it? Either both should have it, or both should not have it.
-----------------------------------
In comment 1 you write: "there are some gaps in the support matrix" Can you please let me know what is that support matrix (if it's related to FormModeler at all), so that maybe I can verify that there are no longer gaps?

I just want to make sure that the field properties have been reviewed correctly. Let me know if you are satisfied with the currently available properties of the predefined field types or if one more review is needed.
Comment 5 Pedro Zapata 2014-02-14 11:32:05 EST
There are some properties which  are not currently supported for some types. We will add this support for future releases. I reported a JIRA (https://issues.jboss.org/browse/JBPM-4248) to keep track of this task for future releases.
Comment 6 Jan Hrcek 2014-03-07 08:11:08 EST
Ok, apart from the issues mentioned in comment 4, the commits for this bugzilla are present in BPMS 6.0.1 ER2. Closing this as verified.

Note You need to log in before you can comment on or make changes to this bug.