Bug 1010922 - Firefox should use the GStreamer backend
Firefox should use the GStreamer backend
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 05:51 EDT by Arun Raghavan
Modified: 2014-02-12 09:41 EST (History)
4 users (show)

See Also:
Fixed In Version: xulrunner-27.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 22:43:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arun Raghavan 2013-09-23 05:51:08 EDT
Firefox has had a GStreamer backend for decoding audio for a while now. This is quite handy since it enables supports for restricted codecs such as h.264, aac and mp3 which users otherwise need Adobe Flash for. Upstream is going this route already (https://bugzilla.mozilla.org/show_bug.cgi?id=794282).
Comment 1 Martin Stransky 2013-10-11 15:39:45 EDT
Unfortunately the gstreamer support is not ready yet. Jan is tracking it.
Comment 2 Mikko Tiihonen 2013-12-16 04:02:59 EST
The tracked bug is now fixed in Firefox 26, which is available in all Fedora releases.
Comment 3 Arun Raghavan 2013-12-17 22:12:54 EST
I see '--disable-gstreamer' in about:buildconfig with 26.0 (3.fc20), no h.264 support in http://html5test.com/
Comment 4 Fedora Update System 2014-02-04 13:56:31 EST
xulrunner-27.0-1.fc20,firefox-27.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xulrunner-27.0-1.fc20,firefox-27.0-1.fc20
Comment 5 Fedora Update System 2014-02-04 13:56:56 EST
xulrunner-27.0-1.fc19,firefox-27.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xulrunner-27.0-1.fc19,firefox-27.0-1.fc19
Comment 6 Fedora Update System 2014-02-05 22:43:11 EST
xulrunner-27.0-1.fc20, firefox-27.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2014-02-12 09:41:48 EST
xulrunner-27.0-1.fc19, firefox-27.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.