Bug 1010961 - :reload operation does not activate hornetq object store to be used
:reload operation does not activate hornetq object store to be used
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: tom.jenkinson
Ondrej Chaloupka
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 07:55 EDT by Ondrej Chaloupka
Modified: 2013-12-15 08:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 02:12:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Chaloupka 2013-09-23 07:55:49 EDT
I found out that reload operation on AS server does not activate hornetq object store to be used.
When I set in cli:
/subsystem=transactions:write-attribute(name=use-hornetq-store, value=true)

the XML config file contains correct element. The reload is required. But when I run reload the standard file system object store is still in usage.

There is no message like:
TRACE [com.arjuna.ats.arjuna] (MSC service thread 1-8) HornetqObjectStore.start()

I need to reboot server to get the hornetq store in action.
Comment 1 Ondrej Chaloupka 2013-09-23 08:00:31 EDT
Checked for EAP 6.2.0.ER1.

To reproduce use settings of the logging like:
<logger category="com.arjuna.ats">
    <level name="TRACE"/>
</logger>
<logger category="org.hornetq.journal">
    <level name="TRACE"/>
</logger>

And run $JBOSS_HOME/bin/jboss-cli.sh.

You can compare the logs with case when you set tag
<use-hornetq-store/>
under transactions subsystem by hand in XML.
Comment 2 tom.jenkinson 2013-09-24 11:13:23 EDT
I am not sure what to expect here. I do:

./bin/standalone.sh&
./bin/jboss-cli.sh --connect
/subsystem=transactions:write-attribute(name=use-hornetq-store, value=true)
:shutdown
exit
./bin/standalone.sh

git diff standalone/configuration/standalone.xml
Shows some formatting issues and
+            <use-hornetq-store/>

Is this not what we expect?
Comment 3 Ondrej Chaloupka 2013-09-24 11:18:11 EDT
Hi Tom,

my problem is that when it seems that HornetQ is not started after reload. When I do reboot (stop jboss and start again) then the HornetQ object store is used.

But when I start jboss with standard file system store, set it as attribute and run reload then the standard file system object store is used and it's not switched to the hornetq object store after the restart.

This could be observed when you run some app and check the data directory or when you check the log with trace level. When hornetq is used then after start/reload you should see message HornetqObjectStore.start() somewhere in the log.

Ondra
Comment 4 tom.jenkinson 2013-09-24 11:33:13 EDT
Ah, are you expecting to not need to reboot the server after changing the object store in use? This is not how Narayana works, the object store is set when the transaction manager launches and can't be altered without a restart of the transaction manager.
Comment 5 Ondrej Chaloupka 2013-09-25 02:12:06 EDT
Ah, ok, then... I didn't realize that before. Sorry for creating this bug.

Summary: This is not a bug this is expected behavior. Narayana needs to be restarted to start to use new object store.

Note You need to log in before you can comment on or make changes to this bug.