Bug 1010976 - After 2 days of being UP, JON server runs out of database connections
After 2 days of being UP, JON server runs out of database connections
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Database (Show other bugs)
JON 3.2
Unspecified Unspecified
urgent Severity urgent
: ER02
: JON 3.2.0
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks: jon32-Beta-Blockers-1006862 1012435
  Show dependency treegraph
 
Reported: 2013-09-23 08:38 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:33:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-09-23 08:38:55 EDT
Description of problem: I am hitting ResourceException: IJ000655 when my JON server runs +- 2 days. After this amount of time, server is unable to log me in through UI and server log is full of messages like:

Caused by: javax.resource.ResourceException: IJ000453: Unable to get managed connection for java:jboss/datasources/RHQDS
        at org.jboss.jca.core.connectionmanager.AbstractConnectionManager.getManagedConnection(AbstractConnectionManager.java:390)
        at org.jboss.jca.core.connectionmanager.tx.TxConnectionManagerImpl.getManagedConnection(TxConnectionManagerImpl.java:368)
        at org.jboss.jca.core.connectionmanager.AbstractConnectionManager.allocateConnection(AbstractConnectionManager.java:464)
        at org.jboss.jca.adapters.jdbc.WrapperDataSource.getConnection(WrapperDataSource.java:139)
        ... 86 more
Caused by: javax.resource.ResourceException: IJ000655: No managed connections available within configured blocking timeout (300
00 [ms])

When I stopped server, I got a lot of these warnings

22:40:09,241 WARN  [org.jboss.jca.core.connectionmanager.pool.strategy.PoolBySubject] (MSC service thread 1-1) IJ000615: Destroying active connection in pool: RHQDS (org.jboss.jca.adapters.jdbc.xa.XAManagedConnection@8b3d9a0)


so it looks like there is a bug in code that does not close connections properly.

Version-Release number of selected component (if applicable):
JON 3.2.ER1

How reproducible: so far always


Additional info: I am hitting this behavior on both Windows x64 and Linux environments.
Comment 2 John Sanda 2013-09-23 09:06:53 EDT
I think that this is the same as bug 1009640 which will be fixed in ER2.
Comment 3 Heiko W. Rupp 2013-09-27 05:58:48 EDT
Setting target according to comment 2
Comment 5 Libor Zoubek 2013-10-04 03:02:31 EDT
verified on JON 3.2.0.ER02

Note You need to log in before you can comment on or make changes to this bug.