Bug 1010977 - no cursor in login screen on Plugable UD-160-M mutiseat device
Summary: no cursor in login screen on Plugable UD-160-M mutiseat device
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-23 12:38 UTC by Tomas Pelka
Modified: 2015-11-19 04:18 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-server-1.17.2-7.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 04:18:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2198 normal SHIPPED_LIVE Xorg server and driver bug fix and enhancement update 2015-11-19 08:04:34 UTC

Description Tomas Pelka 2013-09-23 12:38:56 UTC
Description of problem:
the cursor is not displayed on USB attached multiseat device Plugable UD-160-M.
Cursor came back on successful login. 

Version-Release number of selected component (if applicable):
gdm-3.8.4-6.el7
gnome-shell-3.8.4-5.el7
xorg-x11-server-Xorg-1.14.2-10.el7

How reproducible:
100%

Steps to Reproduce:
1. boot rhel7 machine
2. attache Plugable UD-160-M
3.

Actual results:
no cursor on gdm

Expected results:
there should be a cursor

Additional info:
on the login screen it seems that cursor is just invisible, it doesn't meant it is messing

screen-saver works as expected, I mean cursor is displayed

Comment 2 Ray Strode [halfline] 2014-02-07 20:38:55 UTC
So:

1) gnome-shell (well mutter) is calling XDefineCursor at startup. 
2) gnome-settings-daemon is calling XFixesHideCursor() at startup and XFixesShowCursor() when the user moves the mouse plugged into the device
3) The cursor doesn't show up though.
4) If something calls XDefineCursor a second time (say hover over the password entry, or restart gnome-shell) then the cursor suddenly appears

It looks like an X server bug of some sort.  Since it only happens with pluggable devices, i wonder if it's some sort of hotplug race?

Moving to X server.

Comment 3 Adam Jackson 2014-02-25 19:27:46 UTC
Does this build fix it?

http://people.redhat.com/~ajackson/swcursor/

Comment 4 Adam Jackson 2014-03-05 15:01:15 UTC
Well it had better, because that change is included in RHEL7 now.

Comment 14 errata-xmlrpc 2015-11-19 04:18:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html


Note You need to log in before you can comment on or make changes to this bug.