Bug 1010991 - Patching documentation is in the wrong section
Patching documentation is in the wrong section
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: GA
: EAP 6.2.0
Assigned To: Lucas Costi
Jan Martiska
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 09:03 EDT by Jan Martiska
Modified: 2014-08-14 11:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14873, Installation Guide-6.2-1 Build Date: 18-09-2013 14:19:43 Topic ID: 13441-507286 [Latest]
Last Closed: 2013-12-15 11:48:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2013-09-23 09:03:08 EDT
Chapter 3.7. Patch Installation

This patching-related documentation should be under section 
"4. Upgrade to the Latest Release"
rather than
"3. Installation"

Actually, it should replace the chapter
"4.1. Upgrade the JBoss EAP 6 ZIP Installation"
which will not be relevant anymore (since 6.2).
Comment 1 Jan Martiska 2013-10-29 09:18:57 EDT
Update and more explanation:

Link to the wrongly placed chapter is [1]. The chapter as I mentioned it earlier, "Upgrade the JBoss EAP 6 ZIP Installation" [2], should not be deleted after all. It discusses the upgrade to a new minor release (eg. 6.3 to 6.4), while [1] discusses upgrade to a new micro release (eg. 6.2.2 to 6.2.3). Patches for the patching mechanism will only be used for upgrading between micro releases.

So these two chapters should be kept close together and it should be made clear that [1] is for micro releases (also called cumulative patches) and [2] is for minor releases. They should both be in the chapter "Upgrade instructions" [3], not "Install Instructions".

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html-single/Installation_Guide/index.html#sect-Install_Patches_in_Zip_Form

[2] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html-single/Installation_Guide/index.html#Upgrade_the_JBoss_Enterprise_Application_Platform_6_ZIP_Installation

[3] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html-single/Installation_Guide/index.html#chap-Upgrade_Instructions
Comment 2 Lucas Costi 2013-10-29 20:53:09 EDT
Russell has suggested we get confirmation from PM on Comment 1 before setting the patching mechanism (micro, but not minor updates) in stone in the docs. Setting a needinfo for John Doyle.
Comment 7 Lucas Costi 2013-11-03 23:33:49 EST
New fix is on-stage and ready for review (changes were made to the 'Summary' of "5.3.1. Upgrade the JBoss EAP 6 ZIP Installation") (Revision 2.0-11):

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html-single/Installation_Guide/index.html#Upgrade_the_JBoss_Enterprise_Application_Platform_6_ZIP_Installation
Comment 8 Jan Martiska 2013-11-04 03:16:28 EST
Looks good now, thanks.

Note You need to log in before you can comment on or make changes to this bug.