Bug 1011012 - Subscribing with activation key stopped working after adding new custom repo
Subscribing with activation key stopped working after adding new custom repo
Status: CLOSED DUPLICATE of bug 1011005
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
All Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 09:25 EDT by Tom McKay
Modified: 2014-06-19 15:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1011005
Environment:
Last Closed: 2013-09-23 09:46:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2013-09-23 09:25:50 EDT
+++ This bug was initially created as a clone of Bug #1011005 +++

Description of problem:

Subscription with activation keys worked fine until I created a new custom repo and attached it to the activation key.

Now I'm getting: "Multi-entitlement not supported for pool with id '...'" when I try using the key.

I've tried creating a new AK and adding repos to it:
- Added RHEL repo - works ok
- Added another custom repo - failure

May be worth pointing out that I have 15 or so custom repos and those were added over time with no problems. I did not do any updates on Katello server.

# rpm -qa|grep katello
katello-common-1.3.26-1.el6.noarch
katello-glue-candlepin-1.3.26-1.el6.noarch
katello-cli-1.3.12-1.el6.noarch
katello-repos-1.3.4-1.el6.noarch
katello-configure-1.3.11-1.el6.noarch
katello-glue-pulp-1.3.26-1.el6.noarch
katello-glue-elasticsearch-1.3.26-1.el6.noarch
katello-1.3.26-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-common-1.3.12-1.el6.noarch
katello-certs-tools-1.3.1-1.el6.noarch
katello-selinux-1.3.2-1.el6.noarch
katello-all-1.3.26-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
Comment 1 Tom McKay 2013-09-23 09:46:05 EDT

*** This bug has been marked as a duplicate of bug 1011005 ***

Note You need to log in before you can comment on or make changes to this bug.