Bug 1011013 - add PERSISTENT_DHCLIENT=1 to ifcfg-eth0
Summary: add PERSISTENT_DHCLIENT=1 to ifcfg-eth0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: guest-images
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-23 13:28 UTC by Joey Boggs
Modified: 2014-03-12 13:43 UTC (History)
7 users (show)

Fixed In Version: rhel-guest-image-6.5-20130926.0.el6
Doc Type: Bug Fix
Doc Text:
Cause: missing dhclient configuration option caused network disconnection if dhcp failed Consequence: loss of network connectivity Fix: PERSISTENT_DHCLIENT=1 added to ifcfg-eth0 Result: if nic is unable to negotiate a dhcp address it will retry
Clone Of:
Environment:
Last Closed: 2013-11-22 00:22:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1735 normal SHIPPED_LIVE rhel-guest-image bug fix and enhancement update 2013-11-20 22:04:16 UTC

Description Joey Boggs 2013-09-23 13:28:31 UTC
Description of problem:

PERSISTENT_DHCLIENT=1 Needs to be added into ifcfg-eth0 to recover from dhcp errors

Comment 4 Wei Shi 2013-10-31 09:18:36 UTC
Verified:
  rhel-guest-image-6-6.5-20131024.0-1

# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=on
PERSISTENT_DHCLIENT=1

Comment 5 errata-xmlrpc 2013-11-22 00:22:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1735.html

Comment 6 Wei Shi 2014-03-12 02:46:02 UTC
*** Bug 1054949 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.