Bug 101102 - inconsistent scrolling in the package group selection box
Summary: inconsistent scrolling in the package group selection box
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: gtk2 (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-29 03:38 UTC by Geoff Reedy
Modified: 2007-04-18 16:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 14:38:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Geoff Reedy 2003-07-29 03:38:12 UTC
Description of problem:

If the mouse cursor is over an insensitive group heading label or checkbox the
scroll wheel does not scroll the list.  The insensitive widget appears to be
intercepting the events and discarding them without passing them to the parent
container.

How reproducible:

Every time

Steps to Reproduce:
1. Select custom install 
2. In the pacakge group selection select Everything
3. Put the mouse cursor over one of the disabled group headings and use the
scroll wheel.
    
Actual results:

Nothing happens

Expected results:

The list scrolls according to movement of the scroll wheel.

Comment 1 Jeremy Katz 2003-08-13 23:58:39 UTC
This is gtk (reproduced with something far simpler).  Scrolling with the scroll
wheel when your focus is on a desensitized widget seems to not work.  Owen, is
this intentional or a gtk bug?

Comment 2 Owen Taylor 2003-08-14 14:12:05 UTC
It's a GTK+ defect, certainly, if also "working as expected". 
The problem is that GTK+ doesn't have any way of telling that an 
insensitive widget wouldn't normally take the scroll event.

So, it doesn't see any difference between

 - User clicks on insensitive button
 - User scrolls over insensitive scroll widget
 - User scrolls over insensitive button

The event is eaten in all three cases. If you want, assign it 
to GTK+ and I'll file a bug upstream and resolve this one
UPSTREAM. 

Comment 3 Jeremy Katz 2003-08-14 14:26:41 UTC
That was basically what I figured was happening.  Thanks Owen.

Comment 4 Owen Taylor 2003-08-14 14:38:06 UTC
http://bugzilla.gnome.org/show_bug.cgi?id=119881


Note You need to log in before you can comment on or make changes to this bug.