This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1011022 - Auto delay mechanism doesn't work with P2P
Auto delay mechanism doesn't work with P2P
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: linuxptp (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Lichvar
Jimmy Pan
:
Depends On:
Blocks: 1005342
  Show dependency treegraph
 
Reported: 2013-09-23 09:46 EDT by Miroslav Lichvar
Modified: 2015-07-19 20:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: linuxptp-1.4-1.20140318git2b099c.el6
Doc Type: Bug Fix
Doc Text:
Cause: The delay timer wasn't reset when ptp4l was configured to select the delay mechanism automatically and P2P delay mechanism was selected. Consequence: ptp4l didn't make any peer delay measurements. Fix: The P2P timer is reset when P2P mechanism is selected. Result: Peer delay is measured correctly when ptp4l is configured to select the delay mechanism automatically.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:03:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Lichvar 2013-09-23 09:46:04 EDT
Description of problem:
When ptp4l is configured to use the Auto delay mechanism and it receives a P2P request when the E2E delay timer is not running, it will switch to P2P, but not make any P2P requests itself.

Version-Release number of selected component (if applicable):
linuxptp-1.3-1.el7

How reproducible:
easily

Steps to Reproduce:
1. run ptp4l master with P2P
2. run ptp4l slave with Auto
3. monitor slave log

Actual results:
ptp4l not making any clock updates

Expected results:
ptp4l reporting master offsets and making clock updates

Additional info:
This is fixed by upstream commit b366b79306f0d5d8c7da0ae10acdca2b01cb54fe.

Test 18-autodm from https://github.com/mlichvar/linuxptp-testsuite tests this bug.
Comment 2 RHEL Product and Program Management 2013-10-13 21:59:52 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 errata-xmlrpc 2014-10-14 03:03:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1491.html

Note You need to log in before you can comment on or make changes to this bug.