Bug 1011032 - Proxy 5.6 channel not listed by client.proxy.listAvailableProxyChannels
Proxy 5.6 channel not listed by client.proxy.listAvailableProxyChannels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Jan Hutař
:
Depends On:
Blocks: sat560-proxy
  Show dependency treegraph
 
Reported: 2013-09-23 09:59 EDT by Jan Hutař
Modified: 2013-10-01 15:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 15:40:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-09-23 09:59:13 EDT
Description of problem:
Proxy 5.6 channel not listed by client.proxy.listAvailableProxyChannels


Version-Release number of selected component (if applicable):
spacewalk-java-2.0.2-39.el5sat


How reproducible:
1 of 1


Steps to Reproduce:
1. Sync 5.4, 5.5 and 5.6 Proxy channels


Actual results:
# spacewalk-remove-channel -l
[...]
rhel-x86_64-server-5
	redhat-rhn-proxy-5.4-server-x86_64-5
	redhat-rhn-proxy-5.5-server-x86_64-5
	redhat-rhn-proxy-5.6-server-x86_64-5
rhel-x86_64-server-6
	redhat-rhn-proxy-5.5-server-x86_64-6
	redhat-rhn-proxy-5.6-server-x86_64-6
[...]
# python
[...]
>>> client.proxy.listAvailableProxyChannels(idfile)
['5.4', '5.5']


Expected results:
>>> client.proxy.listAvailableProxyChannels(idfile)
['5.4', '5.5', '5.6']
Comment 2 Tomas Lestach 2013-09-23 10:54:55 EDT
Right, 5.6 does not get recognized.

The reason is the channel_product_id not being set for the the proxy 5.6 channels:

rhnschema=# select id, label, channel_product_id from rhnChannel where label like 'redhat%';
 id  |                label                 | channel_product_id 
-----+--------------------------------------+--------------------
 165 | redhat-rhn-proxy-5.4-server-x86_64-5 |                 11
 166 | redhat-rhn-proxy-5.5-server-x86_64-5 |                 12
 167 | redhat-rhn-proxy-5.5-server-x86_64-6 |                 12
 158 | redhat-rhn-proxy-5.6-server-x86_64-5 |                   
 159 | redhat-rhn-proxy-5.6-server-x86_64-6 |                   
(5 rows)
rhnschema=# select id, product, version from rhnchannelproduct;
 id |  product   | version 
----+------------+---------
  1 | rhel       | 6
  2 | rhn-tools  | 6
  3 | rhel       | 5
  4 | rhn-tools  | 5
  5 | ha         | 6
  6 | devtoolset | 6
  7 | rhel       | 6.4
  8 | rhn-tools  | 6.4
  9 | vt         | 5
 10 | proxy      | 5.6
 11 | proxy      | 5.4
 12 | proxy      | 5.5
(12 rows)
Comment 5 Martin Korbel 2013-10-01 09:27:26 EDT
Stage validated with Satellite-5.6.0-RHEL5-re20130926.0-x86_64.

> python
>>> import xmlrpclib, pprint
>>> SATELLITE_URL = "http://<fqdn>/rpc/api"
>>> client = xmlrpclib.Server(SATELLITE_URL, verbose=0)
>>> fo = open("/etc/sysconfig/rhn/systemid", "r+")
>>> str = fo.read();
>>> pprint.pprint(client.proxy.listAvailableProxyChannels(str))
>>> fo.close()
['5.6', '5.4', '5.5']
Comment 6 Clifford Perry 2013-10-01 15:40:02 EDT
Red Hat Satellite Proxy 5.6 has been released. This bug tracked under Proxy. 

This bug either was VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:



Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1392.html

Note You need to log in before you can comment on or make changes to this bug.