Bug 1011069 - RHEL6.5 ipa-server-install --uninstall says client is not configured
RHEL6.5 ipa-server-install --uninstall says client is not configured
Status: CLOSED DUPLICATE of bug 1011044
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Cholasta
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 10:58 EDT by Scott Poore
Modified: 2013-09-24 12:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 12:12:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2013-09-23 10:58:50 EDT
Description of problem:

On upgrade test from RHEL6.3 -> 6.4 -> 6.5, when ipa-server-install --uninstall is run, it does not see the client configured.  So it does not run any client cleanup.
ipa         : DEBUG    args=/usr/sbin/ipactl stop
ipa         : DEBUG    stdout=Stopping pki-ca: [  OK  ]
Stopping httpd: [  OK  ]
Stopping ipa_memcached: [  OK  ]
Stopping named: .[  OK  ]
Stopping Kerberos 5 Admin Server: [  OK  ]
Stopping Kerberos 5 KDC: [  OK  ]
Shutting down dirsrv: 
    PKI-IPA...[  OK  ]
    TESTRELM-COM...[  OK  ]
Stopping CA Service
Stopping HTTP Service
Stopping MEMCACHE Service
Stopping DNS Service
Stopping KPASSWD Service
Stopping KDC Service
Stopping Directory Service

ipa         : DEBUG    stderr=
ipa         : DEBUG    args=/usr/sbin/ipa-client-install --on-master --unattended --uninstall
ipa         : DEBUG    stdout=
ipa         : DEBUG    stderr=IPA client is not configured on this system.


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-16.el6.x86_64 ->
ipa-server-3.0.0-25.el6.x86_64 -> 
ipa-server-3.0.0-36.el6.x86_64

How reproducible:
Always in test automation.  I'm still investigating manual.


Steps to Reproduce:
1.  Install IPA on rhel6.3
2.  Upgrade IPA to version in 6.4
3.  Upgrade IPA to version in 6.5
4.  ipa-server-install --uninstall -U

Actual results:
Shows IPA client is not configured on this system.  This leaves things like sssd running when it should not.

Expected results:
run ipa-client-install --uninstall so that it cleans up everything properly.

Additional info:
Comment 2 Scott Poore 2013-09-23 17:08:19 EDT
I've tried this process with ipa-client-install --uninstall first also and it fails the same way.  This is how I can manually reproduce the issue:

# Start with a RHEL 6.3 server:
service iptables stop
service ip6tables stop
yum -y install ipa-server bind-dyndb-ldap

echo "$(hostname -i) $(hostname -s).testrelm.com" >> /etc/hosts
sed -i "s/^\(HOSTNAME=\).*$/\1$(hostname -s).testrelm.com/" \
    /etc/sysconfig/network
hostname $(hostname -s).testrelm.com

ipa-server-install --setup-dns --forwarder=192.168.122.1 \
    --hostname=$(hostname -s).testrelm.com -r TESTRELM.COM \
    -n testrelm.com -p Secret123 -P Secret123 -a Secret123 -U

# ADD RHEL6.4 YUM REPOS

yum -y update 'ipa*' sssd
ipactl restart

# ADD RHEL6.5 YUM REPOS

yum -y update 'ipa*' sssd
ipactl restart

ipa-server-install --uninstall -U
Comment 3 Martin Kosek 2013-09-24 05:05:50 EDT
Jan, can you please check this one?
Comment 4 Jan Cholasta 2013-09-24 11:52:55 EDT
I was able to reproduce this.

Applying <https://git.fedorahosted.org/cgit/freeipa.git/commit/?id=a7110d7a32b6eb7131ce47655cb14f693681ab01> after updating to 6.5 fixed the issue for me.
Comment 5 Martin Kosek 2013-09-24 12:12:56 EDT
Thank you, Jan.

In that case this bug is a duplicate to Bug 1011044. Closing this one, lets get the patch pushed in scope of Bug 1011044.

*** This bug has been marked as a duplicate of bug 1011044 ***

Note You need to log in before you can comment on or make changes to this bug.