This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1011074 - Change value for address-full-policy from BLOCK to PAGE on the distributed configurations
Change value for address-full-policy from BLOCK to PAGE on the distributed co...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JMS (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: EAP 6.2.0
Assigned To: Clebert Suconic
Miroslav Novak
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 11:02 EDT by Miroslav Novak
Modified: 2013-12-15 11:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
In previous versions of JBoss EAP, the JMS configuration property address-full-policy was set to BLOCK in the product's configuration, meaning that once the maximum configured capacity for messages to a given address was reached, producers would be prevented from sending any further messages to that address. This behaviour has been modified to conform more closely with customer expectations. The new default setting is PAGE, which pages messages recieved while the consumer is over the maximum capacity to disk. These messages will occupy disk space if they are not consumed. This behaviour can be modified by setting the address-policy-full configuration back to BLOCK (or, additionally DROP or FAIL) if required.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:16:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2135 Major Resolved Change distributed config on address settings to Page instead of Block 2015-06-23 07:21:45 EDT

  None (edit)
Description Miroslav Novak 2013-09-23 11:02:33 EDT
Description of problem:
Change default value for address-full-policy from BLOCK to PAGE.
Comment 15 Clebert Suconic 2013-09-23 15:26:37 EDT
I'm changing the name of this issue since the default was already page before. 

This was just about changing that standalone-full, or any other XML file
Comment 21 JBoss JIRA Server 2013-09-25 12:09:17 EDT
Clebert Suconic <clebert.suconic@jboss.com> updated the status of jira WFLY-2135 to Resolved
Comment 23 Miroslav Novak 2013-10-07 04:23:22 EDT
There is PAGE policy in all standalone and domain files/profiles.

Verified in EAP 6.2.0.ER4.
Comment 26 Scott Mumford 2013-11-18 23:01:37 EST
Redrafted the supplied Doc Text for inclusion in the 6.2 Release Notes.

Including the original content here for reference if needed:

"Producing will block if you don't consume message over the current distributed configuration.

Users have been considering this behavior counter intuitive as their producers are hanging whey they were expecting it to page. (some would think it as disk flush or other similar terms)

The distributed file is now being change to PAGE

Now over sent messages will just be paged. Be aware that you will use disk space if you don't consume messages.

You may easily change it back to BLOCK if that's required."

Note You need to log in before you can comment on or make changes to this bug.