Bug 1011077 - Changing Windows VM resolution, changes the primary monitor to larger resolution display.
Changing Windows VM resolution, changes the primary monitor to larger resolut...
Status: CLOSED DUPLICATE of bug 1018180
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 11:11 EDT by Bill Sanford
Modified: 2014-06-04 09:39 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-07 13:04:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2013-09-23 11:11:25 EDT
Description of problem:
I have two displays with a Windows 7x86 VM and both are 1024 x 768 and everything is fine with them at the same resolution. Once I start moving them when they are in windowed mode, things start changing.

Once I start resizing the displays, whichever display has the bigger resolution, virt-viewer sets that to the main display in "Windows -> Screen Resolution" and that display gets shifted to the left in that same configuration dialog box.

Since this is happening, the taskbar gets moved to the main display. I believe this is the correct behavior based on and incorrect behavior.


Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-7.el6.x86_64
rhev-guest-tools-iso-3.3-5.noarch.rpm
RHEL6.5-20130912.n.2
rhev-hypervisor6-6.5-20130910.2.el6ev.noarch.rpm
Windows 7x86 VM


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

/usr/libexec/qemu-kvm -m 2048 -spice port=3001,disable-ticketing,addr=127.0.0.1,seamless-migration=on -vga qxl -device qxl -global qxl-vga.vram_size=67108864 -device virtio-serial -chardev spicevmc,id=vdagent,name=vdagent -device virtserialport,chardev=vdagent,name=com.redhat.spice.0 -chardev spicevmc,name=usbredir,id=usbredirchardev1 -device usb-redir,chardev=usbredirchardev1,id=usbredirdev1,debug=3,filter='0x08:-1:-1:-1:1|-1:-1:-1:-1:0' -readconfig /etc/qemu/ich9-ehci-uhci.cfg /home/images/Win7x86.img -monitor stdio 

/usr/libexec/qemu-kvm -m 2048 -spice port=3002,disable-ticketing,addr=127.0.0.1,seamless-migration=on -vga qxl -device qxl -global qxl-vga.vram_size=67108864 -device virtio-serial -chardev spicevmc,id=vdagent,name=vdagent -device virtserialport,chardev=vdagent,name=com.redhat.spice.0 -chardev spicevmc,name=usbredir,id=usbredirchardev1 -device usb-redir,chardev=usbredirchardev1,id=usbredirdev1,debug=3,filter='0x08:-1:-1:-1:1|-1:-1:-1:-1:0' -readconfig /etc/qemu/ich9-ehci-uhci.cfg /home/images/Win7x86.img -monitor stdio -incoming tcp:127.0.0.1:4444 

remote-viewer spice://127.0.0.1?port=3001
Comment 2 Marc-Andre Lureau 2014-03-07 12:49:59 EST
How is this a regression? compared to what version?

The behaviour has changed a bit in upstream, and all layout logic is now in virt-viewer (it used to be partially in spice-gtk).

The display are ordered based on window position by left-right, top-bottom, id, whenever are reconfiguration is triggered.

That should solve this bug, agreed?
Comment 3 Jonathon Jongsma 2014-03-07 13:04:26 EST
Indeed, this particular bug is fixed upstream. I didn't see this bug earlier, but it's the same as Bug 1018180, which is now in POST.  marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 1018180 ***

Note You need to log in before you can comment on or make changes to this bug.