Bug 10111 - mkraid doesn't do a full match when checking for mounted disks
Summary: mkraid doesn't do a full match when checking for mounted disks
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: raidtools   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-10 14:20 UTC by Kees Cook
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-10 14:20:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kees Cook 2000-03-10 14:20:07 UTC
In the rare situation where you have multiple partitions
defined for one disk and have the 10th partition mounted,
(eg, /dev/sda10), and want to build a raid partition on
the 1st partition (eg, /dev/sda1) "mkraid" will claim that
the partition is mounted (eg "/dev/sda1 mounted!").  This
is due to an incorrect pattern match while reading
/etc/mtab.  ('/dev/sda1' matches '/dev/sda10' incorrectly.)

This can be worked around by temporarily editing out the
10th partition entry in /etc/mtab while mkraid is running
its initial verifications.

Once the raid is actually created, everything is fine.

Comment 1 Erik Troan 2000-08-05 14:29:14 UTC
Fixed in raidtools-0.90-12


Note You need to log in before you can comment on or make changes to this bug.