Bug 1011108 - cannot update to selinux-policy-3.11.1-103.fc18
cannot update to selinux-policy-3.11.1-103.fc18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 11:54 EDT by Dan Horák
Modified: 2013-10-02 21:18 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.11.1-105.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 21:18:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2013-09-23 11:54:53 EDT
Description of problem:
[root@eagle yum.repos.d]# LANG=C yum update selinux-policy
Loaded plugins: auto-update-debuginfo
Resolving Dependencies
--> Running transaction check
---> Package selinux-policy.noarch 0:3.11.1-100.fc18 will be updated
--> Processing Dependency: selinux-policy = 3.11.1-100.fc18 for package: selinux-policy-minimum-3.11.1-100.fc18.noarch
--> Processing Dependency: selinux-policy = 3.11.1-100.fc18 for package: selinux-policy-minimum-3.11.1-100.fc18.noarch
--> Processing Dependency: selinux-policy = 3.11.1-100.fc18 for package: selinux-policy-targeted-3.11.1-100.fc18.noarch
--> Processing Dependency: selinux-policy = 3.11.1-100.fc18 for package: selinux-policy-targeted-3.11.1-100.fc18.noarch
---> Package selinux-policy.noarch 0:3.11.1-103.fc18 will be an update
--> Running transaction check
---> Package selinux-policy.noarch 0:3.11.1-100.fc18 will be updated
--> Processing Dependency: selinux-policy = 3.11.1-100.fc18 for package: selinux-policy-minimum-3.11.1-100.fc18.noarch
--> Processing Dependency: selinux-policy = 3.11.1-100.fc18 for package: selinux-policy-minimum-3.11.1-100.fc18.noarch
---> Package selinux-policy-targeted.noarch 0:3.11.1-100.fc18 will be updated
---> Package selinux-policy-targeted.noarch 0:3.11.1-103.fc18 will be an update
--> Finished Dependency Resolution
Error: Package: selinux-policy-minimum-3.11.1-100.fc18.noarch (@updates)
           Requires: selinux-policy = 3.11.1-100.fc18
           Removing: selinux-policy-3.11.1-100.fc18.noarch (@updates)
               selinux-policy = 3.11.1-100.fc18
           Updated By: selinux-policy-3.11.1-103.fc18.noarch (updates)
               selinux-policy = 3.11.1-103.fc18
           Available: selinux-policy-3.11.1-66.fc18.noarch (fedora)
               selinux-policy = 3.11.1-66.fc18
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


selinux-policy-3.11.1-103.fc18 dropped the -minimal subpackage and likely no Obsoletes is set in main package or another subpackage resulting in broken update path.


Version-Release number of selected component (if applicable):
selinux-policy-3.11.1-103.fc18
Comment 1 Dan Horák 2013-09-23 12:02:32 EDT
[root@eagle yum.repos.d]# rpm -qa selinux-policy\*
selinux-policy-devel-3.11.1-100.fc18.noarch
selinux-policy-minimum-3.11.1-100.fc18.noarch
selinux-policy-3.11.1-100.fc18.noarch
selinux-policy-targeted-3.11.1-100.fc18.noarch
selinux-policy-doc-3.11.1-100.fc18.noarch
Comment 2 Dan Horák 2013-09-23 12:18:07 EDT
http://pkgs.fedoraproject.org/cgit/selinux-policy.git/commit/?h=f18&id=7ebc712d65b6f3c4c833b2a0de6d6c05735be72b removes the minimal and mls subpackages without adding the required Obsoletes tags
Comment 3 Miroslav Grepl 2013-09-24 10:38:08 EDT
Fixed in selinux-policy-3.11.1-101.fc18.noarch
Comment 4 Miroslav Grepl 2013-09-24 10:39:26 EDT
I meand

selinux-policy-3.11.1-104.fc18
Comment 5 Miroslav Grepl 2013-09-24 10:42:40 EDT
(In reply to Miroslav Grepl from comment #4)
> I meand
meant
> 
> selinux-policy-3.11.1-104.fc18
Comment 6 Fedora Update System 2013-09-24 12:04:56 EDT
selinux-policy-3.11.1-104.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-104.fc18
Comment 7 Fedora Update System 2013-09-26 02:09:32 EDT
Package selinux-policy-3.11.1-104.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-104.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17624/selinux-policy-3.11.1-104.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-09-26 09:23:53 EDT
selinux-policy-3.11.1-105.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-105.fc18
Comment 9 Fedora Update System 2013-10-02 21:18:32 EDT
selinux-policy-3.11.1-105.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.