Bug 1011129 - The OPENSHIFT_MYSQL_* vars are not available in PHP apps
The OPENSHIFT_MYSQL_* vars are not available in PHP apps
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Vojtech Vitek
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 12:20 EDT by Michal Fojtik
Modified: 2015-05-14 19:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 12:25:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Fojtik 2013-09-23 12:20:53 EDT
Description of problem:

The OPENSHIFT_MYSQL* var are not available in PHP applications, because the passenv is not being updated when the mysql cartridge is added to the gear. This would most probably happen for other Apache based cartridges.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. rhc app create php01 php-5.3
2. rhc add-cartridge mysql --app php01
3. rhc ssh --app php01
4. cat php/configuration/etc/conf.d/passenv.conf  | grep MYSQL

Actual results:

There are no OPENSHIFT_MYSQL_* vars.

Expected results:

OPENSHIFT_MYSQL_* variables should be available for the PHP applications.

Additional info:
Comment 1 Jhon Honce 2013-09-23 12:25:10 EDT
You need to restart the application between step #2 and #3.

Note You need to log in before you can comment on or make changes to this bug.