Bug 1011138 - ipw2200 fails to complete DHCP after associating to RSN network
Summary: ipw2200 fails to complete DHCP after associating to RSN network
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-23 16:32 UTC by Peter Gückel
Modified: 2014-04-22 20:28 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-22 20:28:23 UTC


Attachments (Terms of Use)
requsted output of journalctl -b -u NetworkManager with only wireless connected (35.58 KB, text/plain)
2013-09-26 21:57 UTC, Peter Gückel
no flags Details

Description Peter Gückel 2013-09-23 16:32:23 UTC
Description of problem:
I have wireless set up to start automatically, or in networkmanager parlance, it is managed. It was working fine (came up connected at login) until the last kde-redhat update to 4.11.1 about 10 days ago.

I should add that this doesn't appear to be limited to secured connections. I haven't experimented long enough with unsecured, but I noticed the drops there, too.

Version-Release number of selected component (if applicable):
kde-plasma-networkmanagement-0.9.0.9-1.fc19.x86_64

How reproducible:
Boot computer, program tries endlessly to start network, finally fails and displays a red icon.

Steps to Reproduce:
1.
2.
3.

Actual results:
I have noticed that when open the network configuration dialogue and change the wpa2 password and change it on the router, I can establish a connection, but it is dropped after about 5-10 minutes and cannot be reestablished. Reboot doesn't reestablish the configured behaviour of connecting at login, either. I have to continually change the router password and reboot the computer. I cannot get a connection, if I just change the password and click connect. A reboot is required, and it only connects for a few minutes before dropping again, ad infinitum.

With unsecured connections, I can establish a connection by clicking the icon, but it is dropped and I need to reboot to reconnect. Login/out doesn't work.

Expected results:


Additional info:

Comment 1 Peter Gückel 2013-09-24 16:51:25 UTC
I have yum erased kde-plasma-networkmanagement after learning of (by conincidence) and installing kde-plasma-nm and the wireless problem persists, as noted above.

I no longer think this is a kde-plasma network problem. The problem is also in gnome.

I have, thus, changed the component to NetworkManager. I hope this is correct.

NetworkManager-0.9.8.2-8.git20130709.fc19.[x86_64/i686] - mainly i686, since I don't have wireless on the desktop computer, only on the laptop

Comment 2 Peter Gückel 2013-09-24 17:04:03 UTC
The message that appears on the screen after login is:

Wireless Interface (wlp2s4) - Failed to activate
IP configuration was unavailable

nm-tool shows that the network is active, etc., but no IP address is ever established and then wireless becomes unusable.

Comment 3 Dan Williams 2013-09-26 18:08:45 UTC
Can you attach the output of 'journalctl -b -u NetworkManager' ?

Comment 4 Peter Gückel 2013-09-26 21:57:23 UTC
Created attachment 803614 [details]
requsted output of journalctl -b -u NetworkManager with only wireless connected

I noticed numerous killswitch lines. I want to assure you that the network enable button on the laptop is switched ON.

Comment 5 Dan Williams 2013-09-27 21:00:05 UTC
It looks like things are working OK when connecting to the access point, but like you say, no IP address is ever obtained via DHCP.  Check your firewall rules to make sure they aren't disallowing DHCP.

But, I also notice you're using an 'ipw2200' (or 2915) device.  That device hasn't seen much love upstream in the kernel in quite some time, so it's also possible that the ipw2200 driver might be broken too.  That's actually the most likely possibility, so I'm moving it to the kernel component so they can debug the issue there.

For the kernel team: looks like association works correctly, as the supplicant does get connected.  But data frames do not appear to work, since DHCP does not get a response.

Sep 26 15:44:16 lap NetworkManager[359]: <info> (wlp2s4): supplicant interface state: scanning -> associating
Sep 26 15:44:16 lap NetworkManager[359]: <info> (wlp2s4): supplicant interface state: associating -> associated
Sep 26 15:44:16 lap NetworkManager[359]: <info> (wlp2s4): supplicant interface state: associated -> 4-way handshake
Sep 26 15:44:17 lap NetworkManager[359]: <info> (wlp2s4): supplicant interface state: 4-way handshake -> completed
Sep 26 15:44:17 lap NetworkManager[359]: <info> Activation (wlp2s4/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'dutycalls'.
...
Sep 26 15:44:40 lap dhclient[870]: DHCPDISCOVER on wlp2s4 to 255.255.255.255 port 67 interval 13 (xid=0x4af1233e)
Sep 26 15:44:53 lap dhclient[870]: DHCPDISCOVER on wlp2s4 to 255.255.255.255 port 67 interval 14 (xid=0x4af1233e)
Sep 26 15:45:02 lap NetworkManager[359]: <warn> (wlp2s4): DHCPv4 request timed out.

Comment 6 Peter Gückel 2013-09-28 04:14:50 UTC
I don't know how to check the firewall rules. I never changed a thing, so it should be just the way it comes 'out of the box'. I don't think that's it, but tell me how to check it.

Yes, I am using ipw2200. I never selected it, the installer or whatever selected it automatically. Everything was working just great until about 10-12 days ago, then, suddenly no more wireless. Either a kernel update or a ipw2200-firmware update or a NetworkManager update messed up.

If you want me to use a different device driver, just tell me how to get my built-in laptop wireless working with the new driver.

Comment 7 Peter Gückel 2013-11-08 17:06:08 UTC
It's still not working :-(

Comment 8 Peter Gückel 2013-11-17 20:02:27 UTC
Heads up!

I have reinstalled my system and am now using Fedora 20ß.

There has been no change in this issue! It has metastasized to infect the new release :-(

Comment 9 Peter Gückel 2014-01-13 19:28:13 UTC
Update: still doesn't work.

Comment 10 Jon Heron 2014-02-01 17:14:33 UTC
This serious issue is confirmed on a gateway AMD laptop with realtek RTL8192SE RevP wifi card also.
It stopped working after a kernel update in the fall on F19.
Still persistent in F20...
Regards,
Jon

Comment 11 Justin M. Forbes 2014-02-24 13:58:19 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.13.4-200.fc20.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 12 Peter Gückel 2014-03-03 01:59:14 UTC
I updated the laptop to kernel-3.13.4-200.fc20 and I am still unable to get a wireless network connection.

I have since updated to kernel-3.13.5-200.fc20, but I didn't go through another shutdown and power up cycle to test it yet, but I don't feel optimistic. I will give it a try in a couple of days (I use the laptop daily in good weather, when I will be on the road a lot more).

Comment 13 Peter Gückel 2014-03-04 03:42:29 UTC
I booted the laptop with the wired internet with the latest kernel-3.13.5-200.fc20 and then I disconnected the wire and...

...my wpa2-protected wireless WORKS!

This is the first time I have had a connection in 5 months and I am almost afraid to reboot the computer for fear of having it no longer work when the computer powers back up.

Comment 14 Peter Gückel 2014-03-04 04:02:55 UTC
Okay, I rebooted the computer and I actually do have wireless upon login. The problem FINALLY appears to be successfully solved, thank God!

I noticed a small change:

Formerly, I used to log in and wireless was just there automatically, likely because it is set to connect automatically and it is managed by Network Manager.

Now, I log in and a password window opens up, asking for my password. Upon entry, the wireless network connects instantly.

I am not sure why the change. Either, it is a new protocol in Fedora 20 (remember that the last time this worked, we were still on Fedora 19), or else it could be the change from knetworkmanager to kde-plasma-nm. I don't mind having to open kwallet or pam or seahorse or whatever it is to get a connection, so long as IT WORKS.

Great job! Keep it up.

Comment 15 Peter Gückel 2014-03-04 23:12:02 UTC
Wow!

Comment 16 Peter Gückel 2014-04-22 20:28:23 UTC
I do believe this fixed. It has been working for over a month, over numerous kernel updates.

Thanks for getting it solved.


Note You need to log in before you can comment on or make changes to this bug.