Bug 1011144 - Exception raised by: org.overlord.rtgov.internal.switchyard.EventProcessorManager.close on server shutdown
Exception raised by: org.overlord.rtgov.internal.switchyard.EventProcessorMan...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Gary Brown
Jiri Pechanec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 12:46 EDT by Len DiMaggio
Modified: 2014-07-02 05:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log (264.47 KB, text/plain)
2013-09-23 12:47 EDT, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RTGOV-298 Major Closed Exception from Switchyard EventProcessorManager when shutting down server 2014-07-02 05:19:36 EDT

  None (edit)
Description Len DiMaggio 2013-09-23 12:46:01 EDT
Description of problem:

On an otherwise clean server shutdown - this exception is raised:

12:35:56,065 ERROR [stderr] (ServerService Thread Pool -- 84) javax.management.InstanceNotFoundException: org.switchyard.admin:type=Management.Local
12:35:56,066 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.jmx.PluggableMBeanServerImpl.findDelegate(PluggableMBeanServerImpl.java:94)
12:35:56,066 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.jmx.PluggableMBeanServerImpl.invoke(PluggableMBeanServerImpl.java:263)
12:35:56,067 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.overlord.rtgov.internal.switchyard.EventProcessorManager.close(EventProcessorManager.java:143)
12:35:56,067 ERROR [stderr] (ServerService Thread Pool -- 84) 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
12:35:56,067 ERROR [stderr] (ServerService Thread Pool -- 84) 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
12:35:56,067 ERROR [stderr] (ServerService Thread Pool -- 84) 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
12:35:56,068 ERROR [stderr] (ServerService Thread Pool -- 84) 	at java.lang.reflect.Method.invoke(Method.java:606)
12:35:56,063 INFO  [org.overlord.rtgov.internal.situation.manager.jmx.SituationMgr] (ServerService Thread Pool -- 74) Unregister the Situation Manager MBean
12:35:56,068 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ee.component.ManagedReferenceLifecycleMethodInterceptorFactory$ManagedReferenceLifecycleMethodInterceptor.processInvocation(ManagedReferenceLifecycleMethodInterceptorFactory.java:130)
12:35:56,068 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288)
12:35:56,068 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.WeavedInterceptor.processInvocation(WeavedInterceptor.java:53)
12:35:56,069 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288)
12:35:56,069 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ee.component.ManagedReferenceReleaseInterceptorFactory$ManagedReferenceReleaseInterceptor.processInvocation(ManagedReferenceReleaseInterceptorFactory.java:90)
12:35:56,069 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288)
12:35:56,069 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.WeavedInterceptor.processInvocation(WeavedInterceptor.java:53)
12:35:56,070 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288)
12:35:56,070 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ee.component.NamespaceContextInterceptor.processInvocation(NamespaceContextInterceptor.java:50)
12:35:56,070 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288)
12:35:56,070 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ejb3.tx.CMTTxInterceptor.invokeInOurTx(CMTTxInterceptor.java:248)
12:35:56,071 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ejb3.tx.CMTTxInterceptor.requiresNew(CMTTxInterceptor.java:344)
12:35:56,071 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ejb3.tx.LifecycleCMTTxInterceptor.processInvocation(LifecycleCMTTxInterceptor.java:66)
12:35:56,071 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288)
12:35:56,071 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ejb3.component.interceptors.CurrentInvocationContextInterceptor.processInvocation(CurrentInvocationContextInterceptor.java:41)
12:35:56,072 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288)
12:35:56,072 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ee.component.TCCLInterceptor.processInvocation(TCCLInterceptor.java:45)
12:35:56,072 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:288)
12:35:56,072 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.invocation.ChainedInterceptor.processInvocation(ChainedInterceptor.java:61)
12:35:56,073 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ee.component.BasicComponentInstance.destroy(BasicComponentInstance.java:119)
12:35:56,073 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ejb3.component.singleton.SingletonComponent.destroySingletonInstance(SingletonComponent.java:191)
12:35:56,073 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ejb3.component.singleton.SingletonComponent.stop(SingletonComponent.java:148)
12:35:56,073 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.as.ee.component.ComponentStartService$2.run(ComponentStartService.java:72)
12:35:56,074 ERROR [stderr] (ServerService Thread Pool -- 84) 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
12:35:56,074 ERROR [stderr] (ServerService Thread Pool -- 84) 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
12:35:56,064 INFO  [org.overlord.rtgov.internal.active.collection.jee.ACManagement] (ServerService Thread Pool -- 81) Unregister the ACManagement MBean
12:35:56,065 INFO  [org.overlord.rtgov.internal.epn.jee.jmx.EPNManagement] (ServerService Thread Pool -- 87) Unregister the EPNManagement MBean
12:35:56,077 ERROR [stderr] (ServerService Thread Pool -- 84) 	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
12:35:56,078 ERROR [stderr] (ServerService Thread Pool -- 84) 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
12:35:56,078 ERROR [stderr] (ServerService Thread Pool -- 84) 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
12:35:56,078 ERROR [stderr] (ServerService Thread Pool -- 84) 	at java.lang.Thread.run(Thread.java:724)
12:35:56,078 ERROR [stderr] (ServerService Thread Pool -- 84) 	at org.jboss.threads.JBossThread.run(JBossThread.java:122)




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-09-23 12:47:13 EDT
Created attachment 801787 [details]
Server log
Comment 2 Keith Babo 2013-09-23 12:50:32 EDT
This looks like an RTGov issue.  It's not originating from SwitchYard.  The lookup in RTGov code is failing when looking for a SY admin MBean.
Comment 3 Jiri Pechanec 2013-12-13 03:07:31 EST
Verified in ER7
Comment 4 JBoss JIRA Server 2014-07-02 05:19:36 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-298 to Closed

Note You need to log in before you can comment on or make changes to this bug.