Bug 1011187 - System groups are not visible while adding bulk systems to system group
System groups are not visible while adding bulk systems to system group
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
high Severity low (vote)
: Unspecified
: --
Assigned To: Jason Montleon
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 13:59 EDT by Sachin Ghai
Modified: 2014-04-24 13:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sys groups are not visible (62.79 KB, image/png)
2013-09-23 13:59 EDT, Sachin Ghai
no flags Details
sys groups are visible (56.52 KB, image/png)
2013-10-18 11:01 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-09-23 13:59:00 EDT
Created attachment 801831 [details]
sys groups are not visible

Description of problem:
System groups are not visible while adding bulk systems to system group

Version-Release number of selected component (if applicable):
katello-1.4.6-1.git.246.3deb1a2.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. create two system groups (systems--> system groups).
2. Go to systems--All--> select multiple systems -> click 'Bulk Actions' 
3. Goto system properties --> system groups


Actual results:
system groups are not visible

Expected results:
system group names should be visible to select them, only checkboxes are visible

Additional info:
Using firefox ver 21
Comment 1 RHEL Product and Program Management 2013-09-23 14:15:16 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Walden Raines 2013-10-01 11:13:53 EDT
I cannot reproduce this in master given the steps in the description.  Are there any errors in the javascript console when you encounter this issue?
Comment 4 Walden Raines 2013-10-02 12:02:03 EDT
I tried reproducing this in production mode but still cannot reproduce it.  Can you try updating your instance and seeing if the problem persists?
Comment 5 Walden Raines 2013-10-02 16:08:46 EDT
Moving back to ON_QA as I cannot reproduce this.  Can y'all still reliably reproduce this still?
Comment 6 Sachin Ghai 2013-10-03 05:01:13 EDT
Yes.. its reproducible on latest nightly and using FF21, I'll share the setup details.

katello-1.4.8-1.git.37.b37a904.el6.noarch
Comment 7 Walden Raines 2013-10-04 17:23:48 EDT
This is happening because I was not aware of the process for upgraded gems and thus neglected to upgrade tire from 0.3.13 to 0.6.0.  I proved this by downgrading locally and finally being able to reproduce the issue.
Comment 8 Walden Raines 2013-10-04 17:28:43 EDT
Reassigning to jmontleo@redhat.com because once the updated tire RPM is built this will be fixed.
Comment 10 Sachin Ghai 2013-10-18 11:00:35 EDT
Verified with snap6 compose2 (MDP2)


katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.7-6.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch

sys-groups are visible while adding bulk sys to sysgroup. please see the attachment for verification
Comment 11 Sachin Ghai 2013-10-18 11:01:28 EDT
Created attachment 813807 [details]
sys groups are visible
Comment 12 Bryan Kearney 2014-04-24 13:08:00 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.