Bug 1011192 - pulp-admin rpm repo content rpm with the RHEL 6 repository uses too much RAM
pulp-admin rpm repo content rpm with the RHEL 6 repository uses too much RAM
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: pulp-bugs
pulp-qe-list
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 14:07 EDT by Randy Barlow
Modified: 2015-02-28 16:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:58:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 372 None None None Never

  None (edit)
Description Randy Barlow 2013-09-23 14:07:45 EDT
Create a repository named rhel-6-server, set its feed to the RHEL 6 upstream, and sync it. Then, run this command:

$ pulp-admin rpm repo content rpm --repo-id rhel-6-server

On my machine, it ran out of RAM before it returned, and took a very long time to execute. According to top, it was using more than 2.1 GB of virtual memory (sum of shared libs, swapped memory, and physical RAM) which is probably too much.
Comment 1 Chris Duryee 2014-11-10 08:45:37 EST
This is still outstanding as of pulp 2.5.0-0.17.rc. I tried to run this on a system with 4GB mem and my httpd was killed by the OOM killer. I ran this after syncing http://public-yum.oracle.com/repo/OracleLinux/OL6/latest/x86_64/ which has 22975 rpm units.
Comment 2 Brian Bouterse 2015-02-28 16:58:38 EST
Moved to https://pulp.plan.io/issues/372

Note You need to log in before you can comment on or make changes to this bug.