Bug 1011213 - apcupsd fails to start when using USB serial port device
apcupsd fails to start when using USB serial port device
Status: CLOSED DUPLICATE of bug 544121
Product: Fedora
Classification: Fedora
Component: apcupsd (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 15:25 EDT by John Griffiths
Modified: 2013-09-24 11:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 11:39:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2013-09-23 15:25:23 EDT
Description of problem:
When an USB serial device is used, apcupsd fails to start at system boot even though it is enabled.

Version-Release number of selected component (if applicable):
apcupsd-3.14.10-10.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. install a USB serial device
2. configure apcupsd to use the USB serial device, (DEVICE /dev/ttyUSB0)
3. reboot the system

Actual results:
apcupsd does not start because it cannot connect to the serial device.

Expected results:
apcupsd should start

Additional info:
Using systemctl start apcupsd.service after the system has booted starts apcupsd successfully.
Comment 1 Michal Hlavinka 2013-09-24 05:25:31 EDT
Do you have ModemManager installed?
If you do, try to remove it, reboot and check if apcupsd works or not.
If you need ModemManager, install it back. If you are connected via modem, download ModemManager rpm first (using yumdownloader) so you don't need internet connection to install it back.

Also what is the apcupsd error message exactly?
Comment 2 John Griffiths 2013-09-24 11:20:11 EDT
Yes, I had ModemManager installed. No, did not need it. Removed it and apcupsd started correctly.

Thanks.
Comment 3 Michal Hlavinka 2013-09-24 11:39:24 EDT
Unfortunately, ModemManager steals all (usb)serial devices during boot.

*** This bug has been marked as a duplicate of bug 544121 ***

Note You need to log in before you can comment on or make changes to this bug.