Bug 1011225 - nss-softokn-fips and nss-softokn-freebl-fips need to be added to comps.xml
nss-softokn-fips and nss-softokn-freebl-fips need to be added to comps.xml
Status: CLOSED DUPLICATE of bug 1009708
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Lubos Kocman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 16:25 EDT by Bob Relyea
Modified: 2013-09-23 17:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 17:43:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Relyea 2013-09-23 16:25:35 EDT
Description of problem:
Current composes are missing nss-softokn-fips RPM of nss-softokn package. Content of this RPM was split from nss-softokn RPM and therefore should be added to all variants/channels where nss-softokn RPM currently is.

Without this login with fips=0 will fail QA.

bob
Comment 1 Bill Nottingham 2013-09-23 16:38:39 EDT
Why would this make fips=0 fail (as opposed to fips=1)?

In any case looks more or less like a dup of bug 1009708.
Comment 2 Bob Relyea 2013-09-23 16:47:00 EDT
It would guarrentee fips=1 would fail for users of libfreebl (like libcrypt.so: part of glibc and required for login).

It could cause users that put NSS into FIPS mode (independent of the system fips flag). This is things like servers using modutil to turn of FIPS mode, or users clicking the enable FIPS button in the browser. I don't know how many customers this affects.

It currently has not effect in all other cases, but once the rest of the fips code is in place, it will cause the FIPS integrity check to run, even in non-fips mode, so at the very least it needs to be removable.

bob
Comment 3 Bill Nottingham 2013-09-23 17:13:03 EDT
Right, but comment #0 said it made fips=0 fail, which didn't make much sense to me.
Comment 4 Bill Nottingham 2013-09-23 17:43:51 EDT

*** This bug has been marked as a duplicate of bug 1009708 ***

Note You need to log in before you can comment on or make changes to this bug.