Bug 1011246 - Systems are not visible in the auto-complete dropdown when adding Systems to a System Group
Systems are not visible in the auto-complete dropdown when adding Systems to ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Walden Raines
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 17:08 EDT by bmorriso
Modified: 2014-04-24 13:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Empty auto-complete dropdown with a system name entered (75.79 KB, image/png)
2013-09-23 17:08 EDT, bmorriso
no flags Details
system is visible under auto-complete drop-down (92.29 KB, image/png)
2013-10-21 06:57 EDT, Sachin Ghai
no flags Details

  None (edit)
Description bmorriso 2013-09-23 17:08:57 EDT
Created attachment 801944 [details]
Empty auto-complete dropdown with a system name entered

Description of problem:

On the System Groups page, with a System Group selected in the left pane, entering text into the "Add Systems" text field will not cause auto-completed suggestions to appear. 

If text is entered that is a substring of a valid system name, then the auto-complete dropdown menu will appear, but it is blank with no system names visible.

If text is entered that is not a substring of any existing system name, then the autocomplete dropdown menu will not appear.

Version-Release number of selected component (if applicable):
1.4.6-8.el6sat

How reproducible:
Always

Steps to Reproduce:
1. Navigate to System Groups page
2. Select a System Group from the left pane.
3. Begin typing the name of a system that already exists.

Actual results:
A dropdown menu appears with no system names in it. Clicking on the empty cells in the dropdown menu does not cause any systems to be added to the group.

Expected results:
A list of systems that match the entered text appears, and selecting a system from the dropdown list will fill its name into the text field and allow it to be added to the system group.

Additional info:
Comment 1 RHEL Product and Program Management 2013-09-23 17:15:20 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Walden Raines 2013-09-25 13:08:48 EDT
PR:  https://github.com/Katello/katello/pull/3034
Comment 6 Sachin Ghai 2013-10-21 06:52:30 EDT
Verified with snap6 compose2 (MDP2)

katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.7-6.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch


Systems are now visible in the auto-complete dropdown. and I can select from it to add it into system-group. Please see the screenshot for verification
Comment 7 Sachin Ghai 2013-10-21 06:57:52 EDT
Created attachment 814533 [details]
system is visible under auto-complete drop-down
Comment 8 Bryan Kearney 2014-04-24 13:09:18 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 9 Bryan Kearney 2014-04-24 13:10:49 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.