Bug 1011252 - os-prober fails to detect Windows install on Acer TravelMate
os-prober fails to detect Windows install on Acer TravelMate
Status: CLOSED DUPLICATE of bug 971255
Product: Fedora
Classification: Fedora
Component: os-prober (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Hedayat Vatankhah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 17:53 EDT by Orion Poplawski
Modified: 2013-09-25 10:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 10:41:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages from os-prober run (12.27 KB, text/plain)
2013-09-24 11:39 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2013-09-23 17:53:56 EDT
Description of problem:

Just installed Fedora 19 on an Acer TravelMate B-113M-6825.  os-prober is not detecting the Windows 7 install on it.

[root@pacas ~]# os-prober
[root@pacas ~]# grep -F prober /var/log/messages
Sep 23 15:45:21 pacas root: os-prober: debug: running /usr/libexec/os-probes/50mounted-tests on /dev/sda1
Sep 23 15:45:21 pacas macosx-prober: debug: /dev/sda1 is not an HFS+ partition: exiting
Sep 23 15:45:22 pacas root: os-prober: debug: running /usr/libexec/os-probes/50mounted-tests on /dev/sda2
Sep 23 15:45:22 pacas macosx-prober: debug: /dev/sda2 is not an HFS+ partition: exiting
Sep 23 15:45:25 pacas root: os-prober: debug: running /usr/libexec/os-probes/50mounted-tests on /dev/sda3
Sep 23 15:45:25 pacas root: os-prober: debug: running /usr/libexec/os-probes/50mounted-tests on /dev/sda4
Sep 23 15:45:31 pacas macosx-prober: debug: /dev/sda4 is not an HFS+ partition: exiting
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/50mounted-tests on /dev/sda5
Sep 23 15:45:31 pacas macosx-prober: debug: /dev/sda5 is not an HFS+ partition: exiting
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/50mounted-tests on /dev/sda6
Sep 23 15:45:31 pacas root: os-prober: debug: /dev/sda8: is active swap
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/05efi on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/10freedos on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/10qnx on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/20macosx on mounted /dev/sda9
Sep 23 15:45:31 pacas macosx-prober: debug: /dev/sda9 is not an HFS+ partition: exiting
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/20microsoft on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/30utility on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/40lsb on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/70hurd on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/80minix on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/83haiku on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/90linux-distro on mounted /dev/sda9
Sep 23 15:45:31 pacas root: os-prober: debug: running /usr/libexec/os-probes/mounted/90solaris on mounted /dev/sda9
[root@pacas ~]# blkid
/dev/sda1: LABEL="Recovery" UUID="B2D6ADEDD6ADB251" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="8a111531-ee90-46c7-bf35-dc3a45c7b17b"
/dev/sda2: LABEL="ESP" UUID="42B0-269B" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="95f753bd-7de2-4d39-a8da-e66b0e971e50"
/dev/sda4: LABEL="Acer" UUID="1E2EB22B2EB1FBB9" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a22fa087-7c05-485b-bafd-c6a7bc637a53"
/dev/sda5: LABEL="Push Button Reset" UUID="740EB61C0EB5D778" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="5f95608a-3f33-4f64-9f4f-9d2db21159ff"
/dev/sda7: LABEL="root" UUID="d507f62f-e7e2-4f4a-a31f-fbb9e8849b0e" TYPE="ext4" PARTUUID="7dd7260e-26ca-4aa4-aa57-ff8a1fec39bc"
/dev/sda8: LABEL="swap" UUID="e5bd9618-4c86-4e96-8df5-a48851e3f4a8" TYPE="swap" PARTUUID="9276b81d-cff4-41be-a850-6357f86624ac"
/dev/sda9: LABEL="export" UUID="6c75f47c-8702-4afa-9ef5-119aef5db2b1" TYPE="ext4" PARTUUID="adc189bf-4aa1-47c3-8f40-106633aea8a2"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="9e262a68-662f-4fdc-a6b4-5d3a670fec69"
/dev/sda6: PARTUUID="59f715af-ea77-4b44-8071-22da8190f720"

Version-Release number of selected component (if applicable):
os-prober-1.58-3.fc19.x86_64
Comment 1 Orion Poplawski 2013-09-23 18:35:34 EDT
Contents of Windows 7 dir on /dev/sd4:

book                    Intel          Program Files (x86)
Boot                    OEM            Recovery
BOOTSECT.BAK            pagefile.sys   $Recycle.Bin
Config.Msi              PerfLogs       System Volume Information
Documents and Settings  ProgramData    Users
hiberfil.sys            Program Files  Windows

There appears to be no bootmgr file.  This system is EFI capable, though it is operating in BIOS mode - could that be the issue?
Comment 2 Orion Poplawski 2013-09-23 18:47:45 EDT
If I comment out the bootmgr check:

#if item_in_dir -q bootmgr "$2"; then

in /usr/libexec/os-probes/mounted/20microsoft, it seems to work:

# os-prober
/dev/sda4:Windows 7 (loader):Windows:chain
/dev/sda5:Windows Recovery Environment (loader):Windows1:chain
Comment 3 Orion Poplawski 2013-09-23 18:53:28 EDT
Ah, well while it detects the partition - it can't actually boot it because it has no boot loader.
Comment 4 Orion Poplawski 2013-09-23 21:35:55 EDT
Seems to be related, possible dupe of bug 971255
Comment 5 Hedayat Vatankhah 2013-09-24 06:59:40 EDT
Maybe. Would you please run os-prober (without commenting the bootmgr check line) and provide the full os-prober output in /var/log/messages? Don't use grep, just run 'tailf /var/log/messages' in a separate console before running os-prober, run os-prober and give the complete output of tailf command since running os-prober. Your grep output is incomplete since not all lines include 'prober'.
Comment 6 Orion Poplawski 2013-09-24 11:39:43 EDT
Created attachment 802316 [details]
/var/log/messages from os-prober run

Here you go.

Currently only toggling the disk's pmbr_boot flag with parted allows me to switch between Windows and Linux.
Comment 7 Hedayat Vatankhah 2013-09-25 04:39:30 EDT
Is your Windows installed in EFI mode? or BIOS mode? Fedora is in bios mode, and it seems that Windows is not installed in BIOS mode (i'm not sure). Is this correct? if yes, it is the same bug. 
Looks like that you use GPT, and you have an EFI partition. I wonder how your Windows is booted! :P
Comment 8 Orion Poplawski 2013-09-25 10:41:08 EDT
Windows is in EFI mode - so it's the same issue.

*** This bug has been marked as a duplicate of bug 971255 ***

Note You need to log in before you can comment on or make changes to this bug.