Bug 1011310 - Unhandled exception: Mail service is down
Summary: Unhandled exception: Mail service is down
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Logic   
(Show other bugs)
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5
Assignee: Patrick Huang
QA Contact: Damian Jansen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 994362
TreeView+ depends on / blocked
 
Reported: 2013-09-24 04:33 UTC by Damian Jansen
Modified: 2015-01-26 23:27 UTC (History)
1 user (show)

Fixed In Version: 3.5.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-1802)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-26 23:27:40 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Damian Jansen 2013-09-24 04:33:05 UTC
Description of problem:
If, for whatever reason, the localhost mail server is down/malfunctioning, a user trying to register is presented with the "We're Sorry ... Invalid Transaction" page.
In the event of a mail send failure, it should display an inline "The system is on fire! Please contact the administrator!" error.

Version-Release number of selected component (if applicable):
3.0.3

How reproducible:
Moderate always

Steps to Reproduce:
1. sudo service postfix stop
2. Go to localhost:port/zanata/account/register
3. Fill out and Submit

Actual results:
Exception screen

Expected results:
Something else

Additional info:
Caused by: javax.mail.MessagingException: Could not connect to SMTP host: localhost, port: 25;
  nested exception is:
	java.net.ConnectException: Connection refused
	at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1972) [mail-1.4.5-redhat-1.jar:1.4.5-redhat-1]
	at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:642) [mail-1.4.5-redhat-1.jar:1.4.5-redhat-1]
	at javax.mail.Service.connect(Service.java:295) [mail-1.4.5-redhat-1.jar:1.4.5-redhat-1]
	at javax.mail.Service.connect(Service.java:176) [mail-1.4.5-redhat-1.jar:1.4.5-redhat-1]
	at javax.mail.Service.connect(Service.java:125) [mail-1.4.5-redhat-1.jar:1.4.5-redhat-1]
	at org.jboss.seam.mail.ui.UIMessage.encodeEnd(UIMessage.java:167) [jboss-seam-mail-2.3.1.Final.jar:2.3.1.Final]
	... 106 more

Comment 1 Patrick Huang 2014-07-29 02:49:38 UTC
https://github.com/zanata/zanata-server/pull/544

Comment 2 Damian Jansen 2014-07-31 02:07:29 UTC
Verified

Comment 3 Sean Flanigan 2014-11-10 06:32:37 UTC
At least the old message included the SMTP host and port.  The new version has a friendlier message, but there's no need to discard the original information.

See https://github.com/zanata/zanata-server/pull/632


Note You need to log in before you can comment on or make changes to this bug.