Bug 1011315 - tigervnc-server missing Requires: libXfont
tigervnc-server missing Requires: libXfont
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tigervnc (Show other bugs)
6.4
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
: 918595 (view as bug list)
Depends On:
Blocks: 1271696
  Show dependency treegraph
 
Reported: 2013-09-24 00:58 EDT by Bill McGonigle
Modified: 2016-05-10 16:09 EDT (History)
6 users (show)

See Also:
Fixed In Version: tigervnc-1.1.0-17.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:09:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill McGonigle 2013-09-24 00:58:02 EDT
Description of problem:

  Missing Requires: libXfont

Version-Release number of selected component (if applicable):

  tigervnc-server-1.1.0-5.el6_4.1.x86_64

How reproducible:

  Always

Steps to Reproduce:
1. clean install, minimal Desktop
2. install/configure tigervnc-server
3. attempt to start tigervnc-server service

Actual results:

  [dix] Could not init font path element /usr/share/X11/fonts/misc, removing from list!
  [dix] Could not init font path element /usr/share/X11/fonts/100dpi, removing from list!
  [dix] Could not init font path element /usr/share/X11/fonts/Type1, removing from list!
  [dix] Could not init font path element /usr/share/fonts/default/Type1, removing from list!
  [dix] Could not init font path element built-ins, removing from list!


Expected results:

  normal startup

Additional info:

  workaround: 

    yum install libXfont
Comment 1 Tim Waugh 2013-09-24 06:19:02 EDT
tigervnc-server requires "libXfont.so.1()(64bit)", which is provided by the libXfont package.

If you now try "yum remove libXfont", does it say it will need to remove tigervnc-server as well?
Comment 3 Jan Grulich 2015-03-19 11:34:00 EDT
*** Bug 918595 has been marked as a duplicate of this bug. ***
Comment 6 Bill McGonigle 2015-11-03 13:57:53 EST
This is working for me as of now (both on install and remove) on EL6.7:

Installing:
 tigervnc-server                                                  x86_64                                              1.1.0-16.el6.centos                                               base                                                 1.0 M
Installing for dependencies:
 libXfont                                                         x86_64                                              1.4.5-5.el6_7                                                     updates                                              137 k
 xorg-x11-font-utils                                              x86_64                                              1:7.2-11.el6                                                      base                                                  75 k
 xorg-x11-fonts-misc                                              noarch                                              7.2-11.el6                                                        base                                                 5.8 M

Transaction Summary
Comment 7 Jan Grulich 2015-11-18 06:11:38 EST
Fixed in tigervnc-1.1.0-17.el6.
Comment 12 errata-xmlrpc 2016-05-10 16:09:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0775.html

Note You need to log in before you can comment on or make changes to this bug.