Bug 1011365 - Solution needed for JBAS010213: Cannot acquire lock default-host
Solution needed for JBAS010213: Cannot acquire lock default-host
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering (Show other bugs)
6.1.1
x86_64 Windows
unspecified Severity urgent
: ---
: ---
Assigned To: Paul Ferraro
Jitka Kozana
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 03:20 EDT by johnborgjacob
Modified: 2014-10-25 08:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-12 10:11:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
standalone-ha (34.69 KB, text/xml)
2013-09-24 03:20 EDT, johnborgjacob
no flags Details

  None (edit)
Description johnborgjacob 2013-09-24 03:20:26 EDT
Created attachment 802066 [details]
standalone-ha

Description of problem: BAS010213: Cannot acquire lock default-host


Version-Release number of selected component (if applicable): Redhat EAP 6.1.1


How reproducible: every time


Steps to Reproduce:
setup a mod_jk loadbalance setup using standalone-ha configuration
enable session replication in the application
the first time the request is processes correctly in second or subsequent times the session lock happens
this is supposedly fixed as per 
https://bugzilla.redhat.com/show_bug.cgi?id=900204
but its still happening resulting in session replication not to be used and application is not usable

Actual results:
Session locking happens

Expected results:
Sesssion lock should not happen

Additional info:
attached my standalone-ha file for reference
Comment 1 johnborgjacob 2013-09-24 05:57:27 EDT
Got this issue fixed by placing jboss-web.xml in web.xml, it would be good if this is updated in the documentation.
Comment 2 johnborgjacob 2013-09-24 05:58:43 EDT
What i meant was, got this issue fixed by placing jboss-web.xml in web-inf folder, it would be good if this is updated in the documentation.
Comment 4 Paul Ferraro 2014-03-05 11:42:39 EST
Do you have a stack trace?
Comment 6 johnborgjacob 2014-03-06 11:22:57 EST
(In reply to Paul Ferraro from comment #4)
> Do you have a stack trace?

Its been a long time since this issue happened I didn't keep the trace. The issue got resolved by placing jboss-web.xml in web-inf folder, if you still want the trace its the same as in the original defect (https://bugzilla.redhat.com/show_bug.cgi?id=900204)

my request is to update the docs so that its easier to solve

Note You need to log in before you can comment on or make changes to this bug.