Bug 1011379 - Not possible to reload server when JTS transactions are activated
Not possible to reload server when JTS transactions are activated
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER6
: EAP 6.2.0
Assigned To: tom.jenkinson
Ondrej Chaloupka
:
Depends On: 1012986
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 03:45 EDT by Ondrej Chaloupka
Modified: 2017-10-09 20:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:16:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBTM-1941 Major Closed When an orb is recreated the JacOrbRCServiceInit class uses a cached poa rather than a new poa linked to the new orb ref... 2014-07-02 08:35:10 EDT
JBoss Issue Tracker WFLY-1569 Major Resolved Not possible to reload server when JTS transactions are activated 2014-07-02 08:35:11 EDT

  None (edit)
Description Ondrej Chaloupka 2013-09-24 03:45:36 EDT
:reload operation fails when transactions are set to run with jts

How to reproduce:
 - active jts transactions
 -- add <jts/> tag under transactions subsystem
 -- set attribute transactions to on for jacorb subsystem
 - run server
 - run :reload with jboss-cli.sh

You'll get exception like this:
WARN  [com.arjuna.ats.jts] (MSC service thread 1-5) ARJUNA022083: JacOrbRCServiceInit - Failed to start RC service: org.omg.CORBA.OBJECT_NOT_EXIST: POA destroyed
 at org.jacorb.poa.POA.checkDestructionApparent(POA.java:1409)
 at org.jacorb.poa.POA.set_servant(POA.java:1979)
 at com.arjuna.ats.internal.jts.orbspecific.jacorb.recoverycoordinators.JacOrbRCServiceInit.startRCservice(JacOrbRCServiceInit.java:197) [jbossjts-jacorb-4.17.9.Final-redhat-1.jar:4.17.9.Final-redhat-1]
 at com.arjuna.ats.internal.jts.orbspecific.recovery.RecoveryEnablement.startRCservice(RecoveryEnablement.java:137) [jbossjts-jacorb-4.17.9.Final-redhat-1.jar:4.17.9.Final-redhat-1]
 at com.arjuna.ats.internal.arjuna.recovery.RecActivatorLoader.startRecoveryActivators(RecActivatorLoader.java:66) [jbossjts-jacorb-4.17.9.Final-redhat-1.jar:4.17.9.Final-redhat-1]
 at com.arjuna.ats.internal.arjuna.recovery.RecoveryManagerImple.<init>(RecoveryManagerImple.java:104) [jbossjts-jacorb-4.17.9.Final-redhat-1.jar:4.17.9.Final-redhat-1]
 at com.arjuna.ats.arjuna.recovery.RecoveryManager.initialize(RecoveryManager.java:224) [jbossjts-jacorb-4.17.9.Final-redhat-1.jar:4.17.9.Final-redhat-1]
 at com.arjuna.ats.jbossatx.jta.RecoveryManagerService.start(RecoveryManagerService.java:65) [jbossjts-integration-4.17.9.Final-redhat-1.jar:4.17.9.Final-redhat-1]
 at org.jboss.as.txn.service.ArjunaRecoveryManagerService.start(ArjunaRecoveryManagerService.java:139) [jboss-as-transactions-7.3.0.Final-redhat-1.jar:7.3.0.Final-redhat-1]
 at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
 at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_40]
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_40]
 at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_40]

ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service jboss.txn.ArjunaRecoveryManager: org.jboss.msc.service.StartException in service jboss.txn.ArjunaRecoveryManager: JBAS010101: Recovery manager create failed
 at org.jboss.as.txn.service.ArjunaRecoveryManagerService.start(ArjunaRecoveryManagerService.java:142)
 at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
 at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_40]
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_40]
 at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_40]
Caused by: java.lang.RuntimeException: ARJUNA012364: RecoveryActivator init failed for com.arjuna.ats.internal.jts.orbspecific.recovery.RecoveryEnablement
 at com.arjuna.ats.internal.arjuna.recovery.RecActivatorLoader.startRecoveryActivators(RecActivatorLoader.java:67)
 at com.arjuna.ats.internal.arjuna.recovery.RecoveryManagerImple.<init>(RecoveryManagerImple.java:104)
 at com.arjuna.ats.arjuna.recovery.RecoveryManager.initialize(RecoveryManager.java:224)
 at com.arjuna.ats.jbossatx.jta.RecoveryManagerService.start(RecoveryManagerService.java:65)
 at org.jboss.as.txn.service.ArjunaRecoveryManagerService.start(ArjunaRecoveryManagerService.java:139)
 ... 5 more
Comment 1 tom.jenkinson 2013-09-27 06:34:53 EDT
For information: this has the same severity as 1009931, both are fixed in 4.17.11.
Comment 2 tom.jenkinson 2013-10-01 07:15:26 EDT
https://github.com/jbossas/jboss-eap/pull/478
Comment 3 JBoss JIRA Server 2013-10-01 12:07:46 EDT
Michael Musgrove <mmusgrov@redhat.com> updated the status of jira JBTM-1941 to Closed
Comment 7 Ondrej Chaloupka 2013-10-17 09:00:18 EDT
Verified for EAP 6.2.0.ER6
Comment 8 JBoss JIRA Server 2013-11-29 05:54:10 EST
Stefano Maestri <smaestri@redhat.com> updated the status of jira WFLY-1569 to Resolved

Note You need to log in before you can comment on or make changes to this bug.