Bug 1011386 - NPE when executing LEFT OUTER JOIN query
NPE when executing LEFT OUTER JOIN query
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: ---
Assigned To: Horia Chiorean
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 03:49 EDT by Horia Chiorean
Modified: 2016-02-10 03:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:57:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-2053 Critical Closed Outer join and two like constrain results NPE 2014-02-17 08:56:18 EST

  None (edit)
Description Horia Chiorean 2013-09-24 03:49:16 EDT
When executing the following query: 

SELECT FROM [test:Parent] as p 
LEFT OUTER JOIN [test:Child] as c ON ISCHILDNODE(c, p) 
WHERE p.[test:parentName] like 'name2%' or c.[test:childName] like 'name2%'

a NullPointerException is raised.
Comment 1 JBoss JIRA Server 2013-09-24 08:21:32 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2053

Fixed NPE caused by missing method implementation in {{SelectComponent}}.
Comment 2 JBoss JIRA Server 2013-09-25 10:59:17 EDT
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-2053

Merged into the 'master' branch. Leaving open until it is also merged into the '3.3.x-prod-ip6.0' branch.
Comment 8 JBoss JIRA Server 2013-10-24 05:21:12 EDT
Randall Hauch <rhauch@jboss.org> updated the status of jira MODE-2053 to Closed
Comment 9 belong 2013-11-19 18:19:45 EST
Fixed before GA - setting to requires_doc_text- accordingly
Comment 10 Filip Nguyen 2014-02-17 08:56:09 EST
Verified in GA.

Note You need to log in before you can comment on or make changes to this bug.