Bug 1011397 - Value of attribute 'derived' is inconsistent for SwitchYardComponentService artifact
Value of attribute 'derived' is inconsistent for SwitchYardComponentService a...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Eric Wittmann
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 04:06 EDT by Stefan Bunciak
Modified: 2014-02-06 10:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:25:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
s-ramp-ui patch to fix this issue (2.46 KB, patch)
2013-09-24 13:30 EDT, Eric Wittmann
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SRAMPUI-110 Major Closed Derived flag incorrect for extended derived artifacts 2013-12-12 09:21:34 EST

  None (edit)
Description Stefan Bunciak 2013-09-24 04:06:46 EDT
Description of problem:

Value of attribute 'derived' is inconsistent for SwitchYardComponentService artifact.

* Artifact details in S-RAMP repository browser:

Type:
SwitchYardComponentService

UUID:
6ff0e58b-a4dc-454a-a35d-d045b34ebc5d

Derived:
false

Date Created:
2013-09-24 by admin
Last Modified:
2013-09-24 by admin


* Downloaded meta-data:
<s-ramp:ExtendedArtifactType extendedType="SwitchYardComponentService" artifactType="ExtendedArtifactType" name="ExampleService" createdBy="admin" uuid="6ff0e58b-a4dc-454a-a35d-d045b34ebc5d" createdTimestamp="2013-09-24T09:46:51.603+02:00" lastModifiedTimestamp="2013-09-24T09:46:53.922+02:00" lastModifiedBy="admin" s-ramp:derived="true" s-ramp:contentType="application/xml">

Version-Release number of selected component (if applicable):
* 6.0.0.ER3

How reproducible:


Steps to Reproduce:
1. Deploy application which contains policy definition so that S-RAMP will derive SwitchYardComponentService for it
2. Check the S-RAMP repository for the inconsistency
3.

Actual results:


Expected results:


Additional info:
Comment 1 Stefan Bunciak 2013-09-24 04:11:44 EDT
This also applies to SwitchYardTransformer & SwitchYardService artifact type.
Comment 2 Stefan Bunciak 2013-09-24 05:06:53 EDT
This is causing these derived artifacts not to show when selected 'Origin' to derived in S-RAMP repository browser.
Comment 3 Eric Wittmann 2013-09-24 10:32:35 EDT
In my testing I haven't been able to confirm that the artifacts fail to come back when 'Origin' is set to Derived.

In my testing my SY app was added to s-ramp, resulting in 64 total artifacts.  When I click Primary it results in 11 being shown, when I click on Derived it results in 53 being shown (albeit paged).

I believe the bug is limited to the Derived column in the list of artifacts and also the "Derived:" section of the artifact details page.
Comment 4 JBoss JIRA Server 2013-09-24 10:43:01 EDT
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira SRAMPUI-110 to Coding In Progress
Comment 5 JBoss JIRA Server 2013-09-24 11:19:36 EDT
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira SRAMPUI-110 to Resolved
Comment 6 JBoss JIRA Server 2013-09-24 11:19:38 EDT
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira SRAMPUI-110 to Closed
Comment 7 Eric Wittmann 2013-09-24 13:30:37 EDT
Created attachment 802376 [details]
s-ramp-ui patch to fix this issue

I have merged the community fix onto the s-ramp-ui product branch (0.3.0.Final-prod-ip6.0).

Additionally, I am attaching a standalone patch file, in case that is desired (more targeted fix for ER3 vs. doing a full rebuild).

NOTE: you should *either* pull latest changes from the s-ramp-ui git repo (product branch) *OR* use the attached patch.  They are the same - I am simply providing options to the prod team. :)
Comment 8 Stefan Bunciak 2013-10-01 06:46:43 EDT
This hasn't been fixed in ER4, I can still reproduce.
Comment 9 Eric Wittmann 2013-10-01 08:56:30 EDT
I'll test with ER4 and see what's up.
Comment 10 Eric Wittmann 2013-10-03 08:16:51 EDT
Looks like the ER4 tag was incorrectly created (by me) for the s-ramp-ui project.  I have re-tagged as:

0.3.1.Final-prod-ip6.0_ER4-2

We can use this if another ER4 build is being done.  If not, then this fix can get in for ER5 instead.
Comment 11 Eric Wittmann 2013-10-03 08:20:12 EDT
Nick, see my previous comment.  Will there be another ER4 build?  

In either case, can you push this bug into whatever state it should be given the details above?
Comment 15 Stefan Bunciak 2013-12-12 09:21:28 EST
Verified in FSW 6.0.0.ER7

Note You need to log in before you can comment on or make changes to this bug.