Bug 1011420 - Unable to open Project screen on IBM java platform
Unable to open Project screen on IBM java platform
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: CR2
: 6.0.0
Assigned To: Mario Fusco
Lukáš Petrovický
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 04:57 EDT by Sona Mala
Modified: 2014-08-06 16:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: This problem is related with IBM java virtual machine (1.6, 1.7) Consequence: There is an error message in GUI and server.log for actions which are related with a project building or an incremental build (save asset, build project, open project, etc.). Workaround (if any): no workaround Result:
Story Points: ---
Clone Of:
Environment:
ibmJava
Last Closed: 2014-08-06 16:15:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (845.80 KB, text/x-log)
2013-09-24 04:57 EDT, Sona Mala
no flags Details
Error screenshot (60.81 KB, image/png)
2013-10-04 05:07 EDT, Jiri Locker
no flags Details
server log on BPMS 6.0.0.ER7 (282.80 KB, text/x-log)
2014-01-14 08:20 EST, Ivo Bek
no flags Details

  None (edit)
Description Sona Mala 2013-09-24 04:57:26 EDT
Created attachment 802103 [details]
server.log

Description of problem:
If you create new project and GUI try to open Project Screen then Error alert is shown

Version-Release number of selected component (if applicable):
6.0.0 ER3, BPMS

How reproducible:


Steps to Reproduce:
1. run BPMS server on ibm distribution of java (1.6 or 1.7) 
2. open business-central on your browser
3. create new repository "myRepo"
4. create new project "myProject"

Actual results:
---------------
Error alert:

Unable to complete your request. The following exception occurred: org.kie.scanner.embedder.MavenEmbedderException: java.util.NoSuchElementException role: org.apache.maven.execution.MavenExecutionRequestPopulator roleHint:

Exception in server.log (is attached)
Loading of Project screen freeze

Expected results:
Open Project Screen without any problem.


Additional info:
Comment 1 manstis 2013-09-24 06:22:56 EDT
Mario, the stack trace suggests this could be a general problem with building Kie Projects with an IBM JRE. Would you mind confirming your KieBuilder tests work with such a JRE (before we look at BPMS/BRMS specifically)? Thanks.
Comment 2 Ivo Bek 2013-09-27 06:42:21 EDT
Yes it's a general problem because I get the same exception via REST API when I install a project.

Here is part of my stacktrace:
[2013-09-26 20:27:07,896] INFO - Installing project 'integration' from repo 'bpms-assets'
[2013-09-26 20:27:08,198] ERROR- Bad entity: [<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<response>
    <status>FAILURE</status>
    <url>/business-central/rest/repositories/bpms-assets/projects/integration/maven/install</url>
    <error>org.kie.scanner.embedder.MavenEmbedderException: java.util.NoSuchElementException
      role: org.apache.maven.execution.MavenExecutionRequestPopulator
  roleHint: </error>
    <stackTrace>org.guvnor.common.services.shared.exceptions.GenericPortableException: org.kie.scanner.embedder.MavenEmbedderException: java.util.NoSuchElementException
      role: org.apache.maven.execution.MavenExecutionRequestPopulator
  roleHint: 
	at org.guvnor.common.services.backend.exceptions.ExceptionUtilities.handleException(ExceptionUtilities.java:24)
	at org.guvnor.common.services.builder.BuildServiceImpl.buildAndDeploy(BuildServiceImpl.java:114)
	at org.guvnor.common.services.builder.BuildServiceImpl$Proxy$_$$_WeldClientProxy.buildAndDeploy(BuildServiceImpl$Proxy$_$$_WeldClientProxy.java)
	at org.kie.workbench.common.services.rest.ProjectResourceDispatcher.installProject(ProjectResourceDispatcher.java:274)
Comment 3 Edson Tirelli 2013-10-01 09:29:59 EDT
This is a nice-to-have for community, but required for product.
Comment 4 Jiri Locker 2013-10-04 05:07:15 EDT
Created attachment 807493 [details]
Error screenshot

This screenshot illustrates how the issue manifests in UI.
Comment 8 Rajesh Rajasekaran 2013-10-29 16:30:37 EDT
Increasing priority of 'TestBlocker' to 'high'
Comment 9 Mario Fusco 2013-11-20 06:51:03 EST
Fixed by https://github.com/droolsjbpm/drools/commit/ff7e0c620
Comment 10 Ivo Bek 2014-01-14 08:11:50 EST
I have still the same problem on BPMS 6.0.0.ER7. I got the NoSuchElementException just after I logged in but also I got it after I created a new project as I followed the reproduce steps. I will attach server log and screenshot.
Comment 11 Ivo Bek 2014-01-14 08:20:01 EST
Created attachment 849931 [details]
server log on BPMS 6.0.0.ER7

I will not attach my screenshot because it is the same as the Error screenshot already there.
Comment 12 Mario Fusco 2014-01-15 07:08:55 EST
Fixed by https://github.com/droolsjbpm/drools/commit/298b3eb17
Comment 13 Edson Tirelli 2014-01-23 11:31:34 EST
Cherry-picked into 6.0.0.GA.x for the 6.0.0.CR2 release:

(6.0.0.GA.x) : https://github.com/droolsjbpm/drools/commit/4b3b175

For completeness, here is the link to 6.0.x commit:

(6.0.x) : https://github.com/droolsjbpm/drools/commit/e34bcc1
Comment 14 Jiri Locker 2014-01-27 06:24:39 EST
Business Central UI tests are no longer blocked by this and are passing on Jenkins with both Java 6 and 7.
Comment 15 Lukáš Petrovický 2014-01-27 07:02:09 EST
In which case, VERIFIED with CR2.

Note You need to log in before you can comment on or make changes to this bug.