Bug 1011430 - [Admin Portal] link to documentation is broken + [text] Warning about missing English 'language pack' - should change to 'documentation'
[Admin Portal] link to documentation is broken + [text] Warning about missing...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Alexander Wels
Pavel Stehlik
ux
:
Depends On:
Blocks: 1019461 3.3snap2
  Show dependency treegraph
 
Reported: 2013-09-24 05:22 EDT by Jiri Belka
Modified: 2014-01-21 17:22 EST (History)
7 users (show)

See Also:
Fixed In Version: is21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:14:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19848 None None None Never
oVirt gerrit 20447 None None None Never
oVirt gerrit 20557 None None None Never

  None (edit)
Description Jiri Belka 2013-09-24 05:22:53 EDT
Description of problem:
After clicking on 'Guide' in header of Administration Portal UI, I get warning page in new window about missing English language pack instead of Administration Guide. I have RHEL 6.4 client with English localization.

-%--
It appears that you do not have the English language pack installed. Please have your administrator install the proper language.

Please click here for the English documentation. This message will only be displayed once per session.
-%--

When I click on 'here' link then I can open Administration Guide from Admin Portal UI header directly, thus no more warning page.

Also 'here' link in second paragraph is almost not visible. It's hard to distinguish black color from blue color of 'here' link.

Version-Release number of selected component (if applicable):
is15

How reproducible:
100%

Steps to Reproduce:
1. have no cookie related to domain of your RHEVM
2. open your RHEVM url (example: https://foobar/
3. in main page, click Administrator Portal
3. log in
4. click Guide link in header

Actual results:
warning new window instead of the guide

Expected results:
guide

Additional info:
Comment 1 Einav Cohen 2013-10-02 18:42:36 EDT
need to replace "language pack" with "documentation".
[i.e. should be: "It appears that you do not have the English documentation installed. ..."]
it will also match the second line in this page, that says "Please click here for the *English documentation*. ...".
Comment 4 Jiri Belka 2013-10-03 03:06:46 EDT
> When I click on 'here' link then I can open Administration Guide from Admin
> Portal UI header directly, thus no more warning page.

Proofs I was not missing rhevm-doc, right?
Comment 5 Alexander Wels 2013-10-03 09:33:40 EDT
This comes back to the age old question, should the locale have a dash '-' or an underscore in it '_'. The locale used to determine the link in the welcome page and application use an underscore. The documentation uses a dash in their paths. This causes the code to not be able to match up the path, and it determines you don't have the documentation installed. It shows you the warning message after which it redirects you to the English version with the correct dash in the path.
Comment 6 Einav Cohen 2013-10-03 11:40:34 EDT
(In reply to Jiri Belka from comment #4)
> > When I click on 'here' link then I can open Administration Guide from Admin
> > Portal UI header directly, thus no more warning page.
> 
> Proofs I was not missing rhevm-doc, right?

you are right, Jiri - I overlooked that when reading the BZ description, I apologize.
Comment 7 David Botzer 2013-10-07 04:38:06 EDT
3.3/is17.1
1. I cleared history
2. First time I click Guide I get error message
It appears that you do not have the English language pack installed. Please have your administrator install the proper language.

Please click here for the English documentation. This message will only be displayed once per session.

3. Second time I get the help,

Is this correct behaviour ?
Comment 8 Alexander Wels 2013-10-07 08:04:27 EDT
The short answer, yes and no, the long answer:

This is the correct behavior for anything BUT the english documentation. So for instance if you select the french locale in the dropdown on the welcome page (or on the login page). And you go to the documentation AND you don't have the documentation for that particular locale installed. Then you should get the intermediate message stating you don't have the correct documentation installed. It then remembers it showed you this message and won't show it to you again until you close the browser.

This is currently the INcorrect behaviour because it is doing it for the English locale as well as other locales. Working on a patch to correct that.
Comment 9 David Botzer 2013-11-04 08:13:43 EST
Fixed, 3.3/is21
"Guide" link opens english guide correctly,
Fixed, 3.3/is21
Comment 11 Itamar Heim 2014-01-21 17:14:43 EST
Closing - RHEV 3.3 Released
Comment 12 Itamar Heim 2014-01-21 17:22:16 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.