Bug 1011448 - Fail to boot win8/win2012 guest and show "Error Code: 0x0000005D" on Intel(R) Xeon(R) E7- 2860 host
Fail to boot win8/win2012 guest and show "Error Code: 0x0000005D" on Intel(R)...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Hai Huang
Virtualization Bugs
:
Depends On:
Blocks: 1000882
  Show dependency treegraph
 
Reported: 2013-09-24 06:13 EDT by zhonglinzhang
Modified: 2013-10-16 22:40 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-29 07:17:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error Code: 0x0000005D (40.44 KB, image/png)
2013-09-24 06:14 EDT, zhonglinzhang
no flags Details

  None (edit)
Description zhonglinzhang 2013-09-24 06:13:20 EDT
Description of problem:
Use breaker machine can not boot win8/win2012 guest, but can boot win7 guest.
I add a screenshot to attachment. 

The intel machine information(part of cpuinfo):
processor	: 159
vendor_id	: GenuineIntel
cpu family	: 6
model		: 47
model name	: Intel(R) Xeon(R) CPU E7- 2860  @ 2.27GHz
stepping	: 2
cpu MHz		: 2261.169
cache size	: 24576 KB
physical id	: 7
siblings	: 20
core id		: 9
cpu cores	: 10
apicid		: 243
initial apicid	: 243
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 popcnt aes lahf_lm ida arat epb dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 4521.91
clflush size	: 64
cache_alignment	: 64
address sizes	: 44 bits physical, 48 bits virtual
power management:

Version-Release number of selected component (if applicable):
host kernel: 2.6.32-419.el6.x86_64
qemu-kvm: qemu-kvm-0.12.1.2-2.402.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Boot windows guest:
/usr/libexec/qemu-kvm -M pc -cpu Westmere -enable-kvm -m 4G -smp 4,sockets=1,cores=4,threads=1 -name scalability-test -rtc base=localtime,clock=host,driftfix=slew -k en-us -boot menu=on -spice disable-ticketing,port=5931 -vga qxl -monitor stdio -drive file=/home/win2012-64-virtio.qcow2,if=none,id=drive-system-disk,media=disk,format=qcow2,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-system-disk,id=system-disk,addr=0x9 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=00:22:15:27:54:8d,bus=pci.0,addr=0x8

2.
3.

Actual results:
Failed to boot guest and show the Error Code: 0x0000005D. see attachment

Expected results:
It should boot guest successful

Additional info:
Failed to boot Win8/win2012 guest(boot win7 guest successfully), but can boot successfully in local machine.
Comment 1 zhonglinzhang 2013-09-24 06:14:52 EDT
Created attachment 802141 [details]
Error Code: 0x0000005D
Comment 2 zhonglinzhang 2013-09-27 04:34:20 EDT
with virtlab machine can not reproduce

processor	: 23
vendor_id	: GenuineIntel
cpu family	: 6
model		: 44
model name	: Intel(R) Xeon(R) CPU           X5650  @ 2.67GHz
stepping	: 2
cpu MHz		: 1596.000
cache size	: 12288 KB
physical id	: 1
siblings	: 12
core id		: 10
cpu cores	: 6
apicid		: 53
initial apicid	: 53
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 popcnt aes lahf_lm arat epb dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 5333.20
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management:

Actual Results:
In this machine can boot win8/win2012 guest successfully.
Comment 5 Ronen Hod 2013-09-28 18:39:05 EDT
Qunfang,
I searched the Internet and found out that older CPUs that do not support the NX/XD bit, cannot run Win8 (also on bare metal).
I suggest that you try a different CPU type, and if it works, close the bug.
Thanks, Ronen.
Comment 6 Qunfang Zhang 2013-09-29 01:59:17 EDT
Hi, Ademar and Ronen

Thanks for the reply. From the comment 0, we could see there's no 'nx' flag in the cpu info, but we re-check the system again just now, the 'nx' flag exists! So we will re-test again to see whether the problem is still reproducible. And btw, we tested on some other system, could not reproduce the issue.

Thanks,
Qunfang
Comment 7 zhonglinzhang 2013-09-29 07:17:27 EDT
Retest with the same machine:

processor	: 159
vendor_id	: GenuineIntel
cpu family	: 6
model		: 47
model name	: Intel(R) Xeon(R) CPU E7- 2860  @ 2.27GHz
stepping	: 2
microcode	: 0x36
cpu MHz		: 2261.007
cache size	: 24576 KB
physical id	: 7
siblings	: 20
core id		: 9
cpu cores	: 10
apicid		: 243
initial apicid	: 243
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 popcnt aes lahf_lm ida arat epb dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 4521.89
clflush size	: 64
cache_alignment	: 64
address sizes	: 44 bits physical, 48 bits virtual
power management:


Steps as comment 0

There is nx flag this time, maybe last time(comment 0) disable nx flag. this time can boot win8 guest successful,so I will close this bug, If I am wrong, please let me know it. 

Best Regards!
Comment 9 Ronen Hod 2013-10-16 07:46:19 EDT
Gleb,
Junyi asks about emulating the NX flag on CPUs that do not support it. Maybe you can answer.
Comment 10 Gleb Natapov 2013-10-16 07:53:18 EDT
(In reply to Ronen Hod from comment #9)
> Gleb,
> Junyi asks about emulating the NX flag on CPUs that do not support it. Maybe
> you can answer.

The answer is "no".
Comment 11 juzhang 2013-10-16 22:40:45 EDT
Hi Gleb and Ronen,

Really thanks for your confirmation.

Best Regards,
Junyi

Note You need to log in before you can comment on or make changes to this bug.