Bug 1011460 - Wrong CLI command for rolling back a patch
Wrong CLI command for rolling back a patch
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: GA
: EAP 6.3.0
Assigned To: Misha H. Ali
Russell Dickenson
: Documentation, EasyFix, Triaged
: 1082538 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 06:46 EDT by Jan Martiska
Modified: 2014-08-14 11:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14873, Installation Guide-6.2-1 Build Date: 18-09-2013 14:19:43 Topic ID: 21470-537508 [Latest]
Last Closed: 2014-08-06 10:36:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2013-09-24 06:46:43 EDT
in Procedure 3.14. Rollback a patch from a JBoss EAP 6 server instance using the patch command:

The CLI command
patch rollback PATCH_ID --reset-configuration=TRUE
is wrong.

it should be
patch rollback --patch-id PATCH_ID --reset-configuration=TRUE
Comment 1 Jan Martiska 2013-09-24 06:56:32 EDT
It currently works both ways, but the --patch-id argument was meant to be used and not requiring it is probably a bug in the patching implementation and is in discrepancy with the description provided by 'patch --help' command. So I think we should use the version with --patch-id in the documentation.
Comment 3 Scott Mumford 2014-02-26 00:13:57 EST
Moving to ON_QA.

The changes should be available for review on the documentation stage within an hour or so from this comment.

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/
Comment 4 Scott Mumford 2014-02-26 00:15:51 EST
Moving to ON_QA.

The changes should be available for review on the documentation stage within an hour or so from this comment.

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/
Comment 5 Jan Martiska 2014-02-26 04:52:18 EST
Verified, thanks.
Comment 6 Lucas Costi 2014-04-01 00:30:59 EDT
In addition to this, a minor change has been made to make the command as:
patch rollback --patch-id=PATCH_ID --reset-configuration=TRUE
as in the 'patch --help'
Comment 7 Lucas Costi 2014-04-01 00:32:00 EDT
*** Bug 1082538 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.