Bug 1011521 - session-migration: fireAllRules is ignored.
session-migration: fireAllRules is ignored.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER5
: 6.0.0
Assigned To: Maciej Swiderski
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 09:17 EDT by Marek Baluch
Modified: 2014-08-06 16:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
process (5.81 KB, application/xml)
2013-09-24 09:17 EDT, Marek Baluch
no flags Details
drl (893 bytes, text/plain)
2013-09-24 09:17 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-09-24 09:17:09 EDT
Created attachment 802220 [details]
process

Description of problem:
Having a simple process start->businessRuleTask->end it is not possible to complete such a process when migrated from jbpm5 to jbpm6. First impression is that the call to ksession.fireAllRules() has no effect what so ever.

How to reproduce:
(using the attached process definition and drl)
1) start the process in jbpm5
2) fireAllRules in jbpm6

Env:
mysql55
Comment 1 Marek Baluch 2013-09-24 09:17:31 EDT
Created attachment 802221 [details]
drl
Comment 2 Marek Baluch 2013-09-24 09:39:01 EDT
May be related to BZ-1011514
Comment 3 Maciej Swiderski 2013-09-27 07:21:35 EDT
there were few things missing:
1. incorrect column name in EventTypes table (not backward compatible) see 
2. RuleFLowGroups were not properly loaded from protobuf due to change in RuleFlowGroup/AgendaGroup handling (drools commits)
3. Missing ruleFlowGroup name attribute as in v5 it was not dynamic

jbpm
master
https://github.com/droolsjbpm/jbpm/commit/b10644be448a042a882cd95c5d86791e9adf7ccd

6.0.x
https://github.com/droolsjbpm/jbpm/commit/e508d9152e34ee60fd4c496bb61369139fe2162a

drools
master
https://github.com/droolsjbpm/drools/commit/f7dcfbcb389ed6a4f86c6e7db1caca5d8f0e30d4

6.0.x
https://github.com/droolsjbpm/drools/commit/aeff477c718194f1d73ddb7987b383ea6cf33c4b
Comment 4 Marek Baluch 2013-11-25 06:24:03 EST
Verified on ER5.

Note You need to log in before you can comment on or make changes to this bug.