Bug 1011522 - Cannot build project after adding a knowledge base to kmodule
Cannot build project after adding a knowledge base to kmodule
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity urgent
: ER5
: 6.0.0
Assigned To: manstis
Jiri Locker
:
Depends On:
Blocks: 1128661
  Show dependency treegraph
 
Reported: 2013-09-24 09:18 EDT by Jiri Locker
Modified: 2014-08-11 06:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1128661 (view as bug list)
Environment:
Last Closed: 2014-08-06 16:17:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (10.67 KB, text/plain)
2013-09-24 09:18 EDT, Jiri Locker
no flags Details

  None (edit)
Description Jiri Locker 2013-09-24 09:18:25 EDT
Created attachment 802222 [details]
server.log

Description of problem:
After adding a kbase in Project Screen/Kmodule editor, attempts to build the project fail.

Version-Release number of selected component (if applicable):
ER3

How reproducible:
-

Steps to Reproduce:
1. navigate to mortgages, open Project Editor, switch to Knowledge bases and sessions section
2. add "kbase1", make it default and save changes
3. build the project

Actual results:
Build failed. Problems view reports: Deployment of unit mortgages:mortgages:0.0.1 failed: java.lang.IllegalStateException: Cannot find ksession with name

Expected results:
Build should succeed.

Additional info:
In case the kmodule definition is not valid and the build is expected to fail, the user should be instructed how to fix it. Current error description doesn't explain much. I tried to add ksession and it didn't help.
Comment 1 Jiri Locker 2013-09-24 11:27:48 EDT
I have accidentally found the condition under which it is possible to successfully build the project. There has to be at least one DEFAULT STATEFUL ksession in any kbase.
Comment 2 Edson Tirelli 2013-10-01 09:36:30 EDT
By the description it seems this is an error with the example and/or error feedback.

A Kbase can exist without a default ksession, but in which case the application needs to fetch the session by name.
Comment 6 manstis 2013-10-21 16:54:52 EDT
I tried to replicate with the provided steps and ER4 however was unable to do so. Please re-check and advise further if reported problem persists.

Note You need to log in before you can comment on or make changes to this bug.