Bug 1011645 - Can not copy file from client to guest with vdagent-win-3.3-1.
Can not copy file from client to guest with vdagent-win-3.3-1.
Status: CLOSED DUPLICATE of bug 956146
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-vdagent-win (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Uri Lublin
Desktop QE
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 13:27 EDT by Bill Sanford
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 10:36:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2013-09-24 13:27:36 EDT
Description of problem:
I installed a Windows XP and Windows 7x86 VM on RHEL 6.5 and installed rhev-guest-tools-iso-3.3-5.noarch.rpm on both VMs.

I then copied the vdagent_x86.zip files from vdagent-win-3.3-1 located  https://brewweb.devel.redhat.com/buildinfo?buildID=280963 onto both VMs to replace the existing files and then restarted the RHEV Spice Agent service.

I could not copy & paste or drag & drop any files from guest to client or client to guest after I restarted the service or restarting the VM.

Version-Release number of selected component (if applicable):
RHEL6.5-20130911.n.1
RHEL6.5-Supplementary-20130911.n.0/
rhev-guest-tools-iso-3.3-5.noarch.rpm
vdagent-win-3.3-1

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 Hans de Goede 2013-09-25 13:42:14 EDT
Hi Bill,

Thanks for the bug report. We will need some extra info to futher debug this.

Please note that file drag and drop is only supported from client to guest, and only 1 file at a time (for now). In order for this to work you need the latest vdagent in the guest, as well as the latest remote-viewer + spice-gtk on the client side.

Are you using a windows or a linux client to view the vm?

Can you please try again using a fully up2date RHEL-6.5 as client, then open a nautilus window, select a file there and drag it from the nautilus window to the remote-viewer window.

Then the file should show up on your desktop in the windows machine (if I remember the location where it gets saved correctly for windows).

Regards,

Hans
Comment 8 Bill Sanford 2013-09-25 16:51:48 EDT
Hans,

I looked at https://bugzilla.redhat.com/show_bug.cgi?id=956146 and the "Fixed in version" is vdagent-win-3.3-1. I have that installed. There is no mention of what version of remote-viewer + spice-gtk that I should use. There is also no mention of using Nautilus as the client start point of where to get files from. I would also suggest that we would need to document the minimal versions and the fact that Nautilus is needed as the place to take files from. 

If I could get the minimal versions of packages I should be using, I will build the environment and test it a.s.a.p.

Bill
Comment 13 Paul Vine 2013-10-08 10:36:09 EDT
Closing as duplicate of original RFE bug as that is re-opened and it will contain information about how this is going to be fixed.

*** This bug has been marked as a duplicate of bug 956146 ***

Note You need to log in before you can comment on or make changes to this bug.