This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 1011648 - Atlas segfaults on arm
Atlas segfaults on arm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: atlas (Show other bugs)
rawhide
arm Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
https://sourceforge.net/p/math-atlas/...
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-09-24 13:37 EDT by Orion Poplawski
Modified: 2013-10-03 14:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.10.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-03 14:41:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-09-24 13:37:36 EDT
Description of problem:

atlas is segfaulting on arm.  Enabled tests in atlas package to help figure it out.  See http://koji.fedoraproject.org/koji/taskinfo?taskID=5973628

/builddir/build/BUILD/ATLAS/arm_base/bin/ATLrun.sh: line 4:  9493 Segmentation fault      $atldir/$*

Version-Release number of selected component (if applicable):
atlas-3.10.1
Comment 1 Orion Poplawski 2013-10-02 22:45:32 EDT
I'm building an updated atlas package now.  It adds a missing -DATL_ARM_HARDFP=1 as specified here: http://math-atlas.sourceforge.net/errata.html#armhardfp.  I've also changed to setting the compiler flags as mentioned there for consistency and some clarity (it avoids duplication of flags on the compile line).

It appears that this may have fixed the segfault.  The checks still fail though as seen in this scratch build log: http://kojipkgs.fedoraproject.org//work/tasks/7648/6017648/build.log, so I've kept the arm test disabled for now.
Comment 2 Orion Poplawski 2013-10-03 14:41:08 EDT
I'm calling this fixed with 3.10.1-5
Comment 3 Jerry James 2013-10-03 14:53:37 EDT
Thanks for fixing this, Orion.  It seems to be working for me, too.

Note You need to log in before you can comment on or make changes to this bug.