Bug 1011654 - Quickstarts panel displays unnecessary dialog when user cancels out of directory creation
Quickstarts panel displays unnecessary dialog when user cancels out of direct...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: EAP 6.2.0
Assigned To: Francisco Canas
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 13:56 EDT by Francisco Canas
Modified: 2014-09-03 00:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:17:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francisco Canas 2013-09-24 13:56:23 EDT
Description of problem:
An incorrect dialog appears after user chooses to cancel creation of a new directory in the Quickstarts panel:
"The directory you have chosen either does not exist or is not valid".

How reproducible:
Every time.

Steps to Reproduce:
1. From the Quickstarts installation panel, select a non-existing directory as the installation target. 
2. A dialog pops up asking user if they want to create a directory here. 
3. Hit cancel

Actual results:
The second dialog pops up with the above warning.


Expected results:
No second dialog is necessary since the user already chose to cancel creating a new directory. 

Additional info:
This issue must be fixed in izpack.
Comment 1 Francisco Canas 2013-09-26 13:32:38 EDT
Modified izpack so that no second warning dialog appears when user chooses to cancel out of creating a new directory in the quickstarts panel.

See commit for details:
http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=a82ad3904840c6b3ef39585355197073ebeacc3d
Comment 2 Petr Kremensky 2013-10-04 10:57:26 EDT
Verified on EAP 6.2.0.ER4 installer.

Note You need to log in before you can comment on or make changes to this bug.