Bug 10117 - critical bug with RH6.1 sort
Summary: critical bug with RH6.1 sort
Status: CLOSED DUPLICATE of bug 7020
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: textutils   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-10 22:05 UTC by sidlon
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-11 18:00:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sidlon 2000-03-10 22:05:33 UTC
Sorting the following text with sort 2.0 produces incorrect results when run on a default RH6.1 installation:
   Input:
1.2.345.600
1.2.34.500
1.2.3.456
1.2.456.700
1.2.356.8
1.2.4.5
   Output:
1.2.34.500
1.2.3.456
1.2.345.600
1.2.356.8
1.2.4.5
1.2.456.700

   I have corresponded with Jim Meyering (meyering@ascend.com) from the GNU textutils project, who informed me that this is not a bug with sort itself, but the result of a conflict between sort 2.0 and the value of the environment variable LC_ALL as set by the default installation of RH.  For sort to work properly, LC_ALL must be set to POSIX.  Any other value will lead to incorrect results.  According to Jim, this problem could be fixed by changing the default value for LC_ALL or by fixing the locale tables.

Comment 1 Jeff Johnson 2000-03-11 18:00:59 UTC
*** This bug has been marked as a duplicate of 7020 ***


Note You need to log in before you can comment on or make changes to this bug.